Retevis RT90 Mobile Dual Band DMR Mobile Radio Review

Discussion in 'Amateur Radio News' started by BH6PJL, Feb 24, 2019.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: FBNews-1
ad: Left-2
ad: Left-3
  1. KC2G

    KC2G Ham Member QRZ Page

    "Retevis RT90 Mobile Dual Band DMR Mobile Radio"

    So it isn't just mobile, dual-band, and DMR, it's also mobile?
     
  2. BH3BFE

    BH3BFE Ham Member QRZ Page

    After reading your message, I understand that it is also the quality of products that determines the price. TYT is also a mid-end product in China. Our fans also like big brands, but price is also a factor affecting hobbies.
     
  3. N1WLD

    N1WLD Ham Member QRZ Page

    Rebranded TYT, yes! But I seriously doubt you've owned on, or you wouldn't brand it as "JUNK". I've sold several dozen in my area. Everyone is happy with them, the audio quality, both sent and recieved, is fantastic, and they cost about 1/3 of the equivilent snob brand dmr radios!! I've had ZERO returns and ZERO warranty issues!
    Admitedly, there were problems with the first 2 versions, but they have been corrected in version 3 and newer radios that were released over a year ago.
     
  4. 2E0JTP

    2E0JTP Ham Member QRZ Page

    RT90 Talk Group Programming question:

    I've programmed other makes/models of DMR and thought I had this stuff sussed out, but apparently not.

    How do you set it so that you only hear the Talk Group you are listening on.

    For example: I have the radio set to TG 235 (a UK wide TG), but I can hear transmissions on other Talk Groups that are using the same Time Slot.

    Traditionally, I set a single Talk Group that can hear all conversations on one Time Slot, with all the other Talk Groups only being able to hear a conversation on that specific TG. Just to keep me sane.

    Does this radio have a "promiscuous mode" I've not spotted?
     
  5. 2E0JTP

    2E0JTP Ham Member QRZ Page

    Asking the question prompted the little grey cells to find the answer:

    In the programming software, under the "General Setting" tab. There are two check boxes, labelled: Group Call Match & Private Call Match. Ticking these appears to solve the problem. Just ticking Group Call Match didn't appear to work, weirdly.

    You can also switch these two on/off directly in the radio menu: Utilities: 1 Radio Settings: 12 P-CallMatch / 13 G-CallMatch.

    Sanity restored. :)
     

Share This Page