quisk -- http://james.ahlstrom.name/quisk/index.html (Runs on Linux and Windows) - Supports Softrock, UHFSDR and HiQSDR (hiqsdr.com).

ghpsdr3-alex -- http://napan.ca/ghpsdr3/index.php/Main_Page -- Both Linux and Windows - Supports HPSDR, openHPSDR Hermes, SDR1000, Softrock, UHFSDR, Microtelecom Perseus, RFSPACE SDR-IQ, HiQSDR, Ettus Research USRP, and the rtl-sdr DVB-T dongle.
It's a client server architecture allowing access via the internet from a PC or Android tablet or phone. Both RX and TX supported. For TX a user ID and password are needed.

hamlib -- The usual supported rigs.

fldigi --

gnuradio --

cuSDR -- for HPSDR and openHPSDR Hermes.

Those are the main ones.

Windows Programs that I have tried under Linux in Wine and Crossover Office
PowerSDR --- Problems connecting to rigs.

HDSDR --- runs, I have only tested with the UHFSDR but it should be good for Softrock also.

Kiss Konsole --- Tried it, don't understand the problem and the openHPSDR reflector didn't offer any suggestions when I posted the problem some weeks ago.
Found a Metis/Hermes/Griffin. Checking whether it qualifies
Metis IP from IP Header =
Metis MAC address from payload = 00-04-A3-6A-21-BE
Not on subnet of host adapter! Adapter IP, Adapter mask
No data from Port =
Ready to receive....
raw Discovery data = EF-FE-02-00-04-A3-6A-21-BE-18-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01-01

There is quite a number of other Linux Hamradio programs on http://radio.linux.org.au/, not all up to date.

Linux hardware I own:- x86_64 (openSUSE and Kubuntu on 5 boxes), Pandaboard (Ubuntu ARM), Beaglebone (Ubuntu ARM), Raspberry Pi (Raspbian, redeployed as a backup firewall running IPFire) and ODROID-X (Ubuntu ARM).

BTW, I only run and use Linux.