Yaesu Vx-7r charging problems

Discussion in 'Radio Circuits, Repair & Performance' started by KB9SMV, May 25, 2012.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: MessiPaoloni-1
ad: Left-2
ad: Left-3
ad: Subscribe
  1. KB9SMV

    KB9SMV Ham Member QRZ Page

    I have a Yaesu Vx-7r which i have not used in awhile. I went to go charge my batteries to use the it and the HT shows it's charging , it powers up when plugged in to the charger , you let it charge for hrs and it even comes up w/ the blue light showing it is fully charged , if you unplug it from the charger it won't power up. Or if you turn it on before you unplug it it immediately powers off as soon as you unplug the charger. I checked the voltage on the batteries and they were good . I even bought a new battery thinking maybe my old ones were bad and it does the same thing. I put my multimeter across the charging pins on the HT with the charger plugged in to see if there was a problem in the circuit not giving voltage to the battery and it has 12v while plugged into the charger. Anyone else hear of a problem like this or have any idea what might be the problem? Not gonna put a ton of cash into this good but older HT.
     
  2. KE3WD

    KE3WD Ham Member QRZ Page

    Try cleaning the contacts to batter in the radio with a common pencil eraser, blow out any eraser chips and try charging again.

    Voltage can be measured but it says nothing about available Current, which is needed to actually charge the battery packs...


    73
     
  3. KB9SMV

    KB9SMV Ham Member QRZ Page

    well thanks for the response , i did clean the contacts on the radio when i tested for voltage, and on all the batteries (even the brand new one i just got) . Guess I'll have to look into finding a repair shop. Anyone know of a good one in the upper mid-west?
     
  4. KC0MHW

    KC0MHW Ham Member QRZ Page

    I'm having the same exact issue with my VX-7 sending it off today to Yeasu for repair. Bought a new battery and that did not resolve it for me either. Called Yeasu Tec-Support and they did not have a answer to what might be wrong. One would think that this has happened somewhere to someone before.
     
  5. KB9SMV

    KB9SMV Ham Member QRZ Page

    well if you don't mind after you find out your problem ... could ya give me a heads up what your problem was and how much it cost you roughly?
     
Thread Status:
Not open for further replies.

Share This Page