ad: Schulman-1

Yaesu SCU-17 Support Thread

Discussion in 'Working Different Modes' started by N4EGA, Nov 8, 2014.

ad: L-HROutlet
ad: l-rl
ad: HRDLLC-2
ad: abrind-2
ad: Left-3
ad: Left-2
ad: L-MFJ
ad: L-Geochron
ad: MessiPaoloni-1
  1. PD0Q

    PD0Q Ham Member QRZ Page

    Well..after quite a lot of puzzling the nasty truth finally came out ...... the frigging USb cable itself!!! .no matter to what pc i connected none would load the drivers .. had already tried two different USB cables with no efforts.. just tried a third one today and as if if by magic the 210 USB to UART driver loads. So beware grabbing just any USB cable lying around.. as there are obviously different wired versions !!!! Sorry Mr. Yaesu grin
     
  2. K6CLS

    K6CLS Ham Member QRZ Page

    those may be "charging" cables, which only have GND and +5vDC connected, no + and - Data. Throw those away!
     
  3. IZ2RBR

    IZ2RBR Ham Member QRZ Page

    Buongiorno a tutti

    Ho un FT857 connesso con l'interfaccia SCU17 al software Ham Radio Deluxe. Sono un operatore telegrafico quindi utilizzo un pulsante verticale collegato alla radio. Normalmente in trasmissione ascolto il cw del sidetone attraverso le cuffie collegate all'uscita phone del pannello frontale. Vorrei VISUALIZZARE la mia manipolazione sul DM780 (decoder cw) ma quando trasmetto il waterwall NON visualizza e decodifica nulla a differenza di quando la radio riceve. Qualcuno sa come fare?

    Grazie Esau IZ2RBR
     
  4. K9KQX

    K9KQX Premium Subscriber QRZ Page

    Just got one of these to replace Signalink USB that I was using on my FTDX-5000. After much trial and error I got it to work the way I like.
    First issue I have is I don't like PKT mode on Yeasu radios. I can't stand that they enable 2.4khz wide filter on receive when so many stations on digital go above that. So for years I've worked around that by using my signalink usb to key up the PTT through the Packet cable. Basically the signalink is acting as a VOX and keys up through that rear port. Whats nice about that is I can leave the rig in USB and not USB PKT, giving me the full 3k bandwidth to see.

    When i installed the SCU-17 I lost that ability and i figure out why, but how to work around it.

    First of lets explain how it works by default by using normal PTT via Cat control.
    On the FTDx5000 when using the enhanced com port generally your ham software does PTT via CAT, it'll pull the audio signal from the configured audio source in the following menu items AM(menu 52), Packet Data(menu 69), FM(menu 80), ,SSB(menu 103.

    To use the SCU17 like I did on the Signalink before, by transmitting digital modes in the normal USB mode(Not the USB PKT mode) so that darn 2.4khz BW filter wasn't engaged, I simply changed menu Item 103 from Front to Data. That seemed like a work around, but i still hated the fact that when i switch between phone operations and digital that I'd have to constantly go into this menu item and edit it. Also this would mess up my RCForbs remoteham software too as I'd have to keep going into this menu item to change it.

    What I didn't understand initially is that the Standard com port that gets installed with the SCU-17 could help me force the PTT signal on the Packet Data plug. By forcing a PTT signal on the packet plug, it overrides any PTT signal via CAT control and thus overrides any programming in the radio that force the audio source from the configure menu items list above.
    In my system COM7 is enhanced and COM8 is standard

    So what I did with WSJT-x is enable the enhanced com port for rig control but my PTT method was change to the standard com port and RTS was selected
    upload_2020-11-19_20-44-41.png

    In HRD DM780 i set the PTT signal via serial to Standard COM Port and set RTS checkmark
    upload_2020-11-19_20-45-49.png


    FLRig Control
    set Xcvr enhanced COM port
    set PTT to standard COM port and check off PTT via RTS

    upload_2020-11-19_22-24-10.png upload_2020-11-19_22-24-27.png
    FLdigi
    I had some major problems passing the audio to the rig. My audio out in Windows showed activity when i would tune, but no modulation on the radio. Stumbled across one audio setting that fix the no transmit audio problem. I turned this Modem signal on left and right channels on
    upload_2020-11-19_22-27-19.png

    in FLdigi just set to use FLrig as the rig control option, if your using Flrig( I am in this example since I think for Linux users this is important)
    upload_2020-11-19_22-30-36.png

    And RCForbs Remoteham server settings , change PTT tab under radio configuration to PTT via com, choose standard com port and use RTS
    upload_2020-11-19_22-35-3.png


    In the end when i want to play radio with digital modes, using these settings and an SCU-17 allows me to operate the radio in normal SSB USB, with full receive Bandwidth and not have to deal with the narrow 2.4khz bandwidth of USB Packet mode on a Yaesu FTDX5000. I don't have to mess with Menu settings in the radio either which makes life easier. maybe these settings will work for others.
     
    W7BSB likes this.
  5. KC7MYN

    KC7MYN Premium Subscriber QRZ Page

     
  6. KC7MYN

    KC7MYN Premium Subscriber QRZ Page

    I've been trying to get the SCU 17 to work with my FT 897 for two days. I've loaded the virtual com ports but when I attempt to connect the SCU to my computer I'm unable to find a connection thru HRD. Denies access to the two ports and the SCU is blinking red lights off and on. I've uninstalled the com ports and reinstalled but nothing changes. I got this mess to work once then everything froze up on the computer and I had to turn everything off. Also tried it on my laptop and again it worked once then everything stops working and I can't reconnect to HRD. Any suggestions?
     
  7. K9KQX

    K9KQX Premium Subscriber QRZ Page

    Thats a weird problem. What Operating system are you running? I did a quick search on google about missing com ports after reboot and oh my the complaints are never ending. I'm wondering if there is some other application taking control of the comm port after reboot thus making it unavailable for HRD. Someone mentioned that the Intel Rapid Storage Technology has been known to do that, not sure why it would though. I think if it was me, I'd update the Bios and any drivers from the PC manufacture for the system board, video, sound card etc and then try reinstalling the SCU-17 drivers. the SCU-17 drivers are really nothing more then run of the mill USB to serial port drivers. Many times ham radio manufactures use the same drivers across various models. When i plugged mine in, it found the scu-17. I suspect it was using the drivers left over from when i had my ftdx-3000 plugged into it via the usb cable.

    I don't think the fault is with the SCU-17 or its drivers, but something on the pc and laptop that is in common from a software perspective taking control of that comm port.
     
  8. M0MNE

    M0MNE Ham Member QRZ Page

    Hi guys,
    It's great to find this thread as I just recently bought the Yaesu SCU-17. I bought it after more than a couple of people told me it pretty much works out of the box on MacOSX. This could not be further from the truth in my situation. I have a number of problems I need to overcome.

    RX, no problem. Worked out of the box.

    Firstly, I struggled to get CAT control to work. After searching around the inter webs, I quickly realised that people were using the Silicon Labs USB Drivers on their Macs to use an SCU-17. I installed the latest version 6. They did not work. Nothing. My MacBook could "see" the drivers, but could not use them.

    Then, I discovered in another thread, someone had got version 5.2.3 to work. However, I cannot find that version to download. I tried version 4, which is available as a "legacy" version on the SiLabs website. Bingo! CAT control now works.

    However, I made one single QSO. Then, all subsequent audio is coming out of the laptop speaker!! Ehhhh??? I restart WSJTX, then I can make another QSO. Then after that QSO, it's back to the laptop speaker again!! What on earth is going on?? Can anyone help? The driver is still shown in the WSJTX Radio settings and the USB Audio Codec is still shown in the Audio settings. Nothing has changed. For some reason, it always reverts back to the laptop speaker with no changes reflected in the settings.

    The other problem is, the FSK and PTT lights never light up on the SCU 17. I saw the PTT light come on when I changed the CAT port from /dev/cu.SLAB_USBtoUART to /dev/cu.SLAB_USBtoUART1, but in this situation, the rig gets stuck on TX! Very erratic behaviour.

    Has anyone experienced this and can someone please help? I am running MacOSX version 10.15.7 and WSJTX version 2.2.2
    My radio is a Yaesu FT450D. The drivers I am using are SiLabs CP210x Macintosh OS X VCP Driver v4. The only other drivers I can find to download are SiLabs CP210x Macintosh OS VCP Driver v6 and these drivers do not work at all.

    I cannot find any posts describing precisely my problem. Has anyone successfully managed to configure a Yaesu FT450D to work with SCU-17 on a MacBook Pro running Catalina version 10.15.7 and WSJTX v. 2.2.2?

    People managed to convince me that this thing works out of the box but I was sorely disappointed. I've run out of ideas now and Yaesu provide absolutely zero support for this thing. There is only one useful page in the 32 p instruction booklet and that is the connection diagram.

    Hope someone can help?

    Austin 2E0MNV
     
  9. KC3PBI

    KC3PBI Ham Member QRZ Page

    If you've got cat control, then you can call that part done and move on.

    It may help to keep in mind that Yaesu packed 4 separate devices into that SCU box, but did nothing to actually combine the functions in software. So your Mac (or any other computer) will think you have four completely separate devices connected: a USB hub, two USB-serial adapters and a soundcard. Thus once you've got one device squared away, you can be confident that it has no bearing on the other functions enabled by the SCU.

    If you unplug the SCU from the mac and reconnect again without rebooting the mac, the USB devices will usually re-enumerate with new device IDs, because the computer has no idea if this is the same SCU you had connected before. Default behavior is to treat it as an entirely new device with new IDs that then need to be selected for use in your relevant software. This is a long-standing limitation of USB hotplugging on many platforms, nothing special about a Mac there.

    I'm going with the idea that the soundcard also re-enumerated itself and needs to be reselected in your apps.

    I am aware that Catalina includes a silicon labs driver, but I can't tell you if it is appropriate for use with the SCU. I've also been led to believe that it is, but on the other hand I still use High Sierra on my own Mac. I use the 5.3.5 driver without issue.

    No idea what to tell you about the status lights on the SCU. the last time I used one it was integrated in a fancy go-kit and not visible to the operator, so I never noticed.
     
  10. M0MNE

    M0MNE Ham Member QRZ Page

    Thanks for your quick response. UPADTE: I went into the sound card settings in the Mac OS Midi sound control, and I changed the settings for input and output to 1 channel 16 bit integer 48kHz. Previously it was 2 channel 16bit 48kHz. Now I seem to be able to make multiple QSOs with CAT control and no issues, it no longer reverts to the laptop speaker. I've even had Fldigi working for PSK31 QSO. So all is good, although I do have to use the legacy version 4 SiLabs drivers as v6 does not work. The FSK and PTT lights on the SCU17 do not light up, but I don't really care as long as it's working now. I haven't restarted my laptop yet though. Who knows what will happen when I do that
     

Share This Page