ad: elecraft

Yaesu FT-991A Firmware update failing with "Problem on COM port"

Discussion in 'General Technical Questions and Answers' started by G0GFD, Sep 21, 2018.

ad: L-HROutlet
ad: l-rl
ad: HRDLLC-2
ad: L-Geochron
ad: Left-2
ad: abrind-2
ad: MessiPaoloni-1
ad: Left-3
ad: L-MFJ
  1. G0GFD

    G0GFD Ham Member QRZ Page

    Having sorted out the auto-tuner, I thought I would update the firmware as it still has the orginal. I followed all the procedures on the Yaesu web site, and installed everything correctly on a Windows 10 laptop. Again following the procedures, got to the point where I do the "main" update. When I click on "Write", there is about a 10 second pause, then a message flashed up which says there is no comminication from the radio, and then an Error message box is displayed that says "Problem on COM port".

    I have gone through the same procedure on a Windows 7 laptop, and a Windows 10 desktop system. Always, I get the same message.

    I have installed the Yaesu drivers correctly and selected the correct (extended) com port. I am computer literate, but cannot identify the problem.

    I assume the cable is OK as the RT Systems software works. My conclusion at the momemt is that there is either something wrong with the default setting of the extended com driver, or there is a fault with the radio.

    Has anyone else had this problem and can anyone help please?

    Keith
    G0GFD
     
  2. KC8VWM

    KC8VWM Ham Member QRZ Page

    Most likely a comport communication parameter issue in Windows.

    The comport settings in Windows are not maching the communication parameters used by the firmware scenario.

    Need to go into the Windows Device Manager.

    Next find the comport driver to make the necessary changes so that all the comport communication parameters, such as the comport speed, (baud rate) error correction protocols (if any) etc. match the settings as indicated in the firmware upgrade instructions.

    For example.. (and this is only intended as an example :))

    [​IMG]
     
    Last edited: Sep 21, 2018
    KA9JLM likes this.
  3. KA9JLM

    KA9JLM Ham Member QRZ Page

    I would turn FIFO buffers off.

    It can cause problems and is not needed. Select the correct flow control.

    Good Luck.
     
    Last edited: Sep 21, 2018
    KC8VWM likes this.
  4. G0GFD

    G0GFD Ham Member QRZ Page

    Thank you for the comments so far. I will give these a try tomorrow when I have some more time to devote to it, and feedback the results.
     
    NA0W likes this.
  5. W0KDT

    W0KDT XML Subscriber QRZ Page

    Have you downloaded and installed the serial drivers from the Yeasu web site? I think that is the first step to get access to the radio from a computer. At least it was when I installed FTRestore. WSJT-X seems want use those ports too but is happy because they were already installed.
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    For Win 10, You may have to bless the hardware to make it work.

    MS may be disabling the hardware for security reasons.

    On Win 7 you can tap F9 on boot to disable driver signing endorsement.

    Good Luck.
     
  7. W4NNF

    W4NNF XML Subscriber QRZ Page

    It's unlikely Windows 10 is disabling anything. As VWM says "com port." Not only do you need the correct one as shown in device manager, if you plug the USB cable into a different USB port than previously, you can get a different com port assignment.
     
    WB7OXP likes this.
  8. G0GFD

    G0GFD Ham Member QRZ Page

    I have now tried all the suggestion and nothing solves the problem. Still have the pop-up in Windows saying "Problem on COM port". In the text box underneath the "Write" button in the uploader it says "No acknowledgement from the radio. Please do the folloing procedure again...." I have.

    Does anyone have any further suggestions please?

    Keith
    G0GFD
     
  9. G0GFD

    G0GFD Ham Member QRZ Page

    FINAL UPDATE - Solved. And further information.

    There are parts of the instructions missing in the Yaesu guide, not all information is in one place, and some is conflicting.

    I evenutally changed the ports to 19 and 20, with a baud rate of 4800 in the drivers and also on the radio before I started any updates, although I am not sure this was the problem.

    The instruction conflicts can be seen in the firmware uploader message box and the PDF instructions. The PDF instructions are correct for the MAIN firmware ar Step 3. Do NOT touch the power button when connecting the DC supply and holding TXW + SPLIT. The firmware uploader will then work correctly.

    After updating MAIN, at Step 10 in the printed instructions it omits to tell you that you will see a Yaesu logo on the screen. When you see this, the rig is NOT powered on apparently. Step 11 then works.

    At this stage panic sets in, as the only thing that will happen is the Yaesu logo is displayed and none of the menu buttons work.

    In other Yaesu instructions, it tells you that all 3 updates must be done before the rig will work again - DSP and TFT. Follow these instructions and everything should be OK.

    What you are NOT told is how to enable the 5MHz band. This is in a leaflet delivered with a new boxed product, apparently. Turn the transceiver off. Press and hold the "F" and "MODE" button whist pressing the power on button. The green indicator above the tuning know will blink at 0.5 sec intervals. Press the "MODE" button and the indicator will blink at 1 sec intervals. Press and hold in the "MODE" buuton and the radio will restart, enabling the 5MHz band.

    Next challenge - how do you access the 5MHz band? The instructions say press and hold the "BAND" button and you will see it. Not true. Press the "BAND" button, and then press and hold the "14" button dislayed on the screen. It will then go to the 5MHz band. A quick press of "BAND" and then "14" again will send ot back to the 14MHz band.
     
    W4NNF, KG5NFK and KA9JLM like this.
  10. W2AI

    W2AI QRZ Lifetime Member #240 Platinum Subscriber Life Member QRZ Page

    I don't think Yaesu rigs or their modem interface, SCU-17, are compatible being interfaced with a PC. I do believe Icom or Kenwood have dedicated USB ports on these transceivers for that purpose.
     

Share This Page