Yaesu ft 757gx no xmit

Discussion in 'Radio Circuits, Repair & Performance' started by KM4YTW, Nov 3, 2019.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: MessiPaoloni-1
ad: Left-3
ad: L-MFJ
ad: Left-2
  1. KM4YTW

    KM4YTW Ham Member QRZ Page

    I picked up a yaesu ft 757gx from the stone mountian hamfest . When i powered it on it han no frequency readout display, i traced that back to a bad solder joint. But i still have no transmit. When i hit mox or the mic i hear no relay and no "on air" light on the display. It does cut receive off but no power coming out, i have reset the unit but no change. Im not very familiar with this model. Any ideas to check out ?
    Thanks
     
  2. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    do you have the service manual.
    It has good schematics, block diagrams and a connection drawing with labels for voltage
    I guess its down to measuring what happens at the PA board connectors
    if you have a scope you can scope the input of the PA and see if there's rf going in on xmit, or with another receiver
    you might be able hear if there is any signal generated.
    I would start with CW mode then on to SSB if that works.
    I downloaded the service manual for mine and its quite useful
     
  3. KM4YTW

    KM4YTW Ham Member QRZ Page

    Thanks Rob. I got the service manual downloaded . I was hoping to find a quick fix from someone. I'll start signal tracing and dig into it I guess.
     
  4. KM4YTW

    KM4YTW Ham Member QRZ Page

    Got it, tx 13.8 volt had a broken pin on the pa board. Works great.
    Thanks
     

Share This Page