Yaesu 991a Windows 10 issue

Discussion in 'Computers, Hardware, and Operating Systems' started by KC3PGT, Mar 20, 2021.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Left-2
ad: HRDLLC-2
ad: MessiPaoloni-1
ad: L-MFJ
ad: L-Geochron
ad: abrind-2
  1. KC3PGT

    KC3PGT Platinum Subscriber Platinum Subscriber QRZ Page

    Hi, I'm having a problem with a new computer (Windows 10) and my 991a. I had it working on an old laptop that died, so I know I know the steps to take to install properly. I've downloaded the drivers from Yaesu (and again directly from Silicon Labs). I install said drivers and get confirmation that the install was successful and they are ready to use. I restart the computer. However, when I plug my 991a into my computer, I get "device not recognized". I've repeated this process multiple times. I am using the most current version of the drivers. My computer is fully updated. I restart after the driver install (before plugging in the 991a). I've tried different USB ports, just to make sure. Any ideas of something I might be missing? Thanks in advance. KC3PGT
     
  2. W6IR

    W6IR Ham Member QRZ Page

    One thing that comes to mind is do you have the correct drivers installed for your OS? In other words 64 bit or 32 bit drivers?
     
  3. K1XH

    K1XH Ham Member QRZ Page

    Also try a shorter USB cable
     
  4. G8FXC

    G8FXC XML Subscriber QRZ Page

    Check the Device Manager - you are assuming that it's the serial ports that are causing the problem - but the 991A also includes an analogue IO device. Check the device manager listings for both comm ports and audio devices with the 991A disconnected and again with it plugged in - you should see two new serial ports and an audio device appear as you connect it.

    Martin (g8FXC)
     
    KC3PBI likes this.
  5. KC3PGT

    KC3PGT Platinum Subscriber Platinum Subscriber QRZ Page

    Thanks for the input! I have an update. I've had a fellow from RT systems take over my computer and have a look. We now think it is a USB problem. The computer seems unable to recognize the 991a enough to know to load the driver. I've run device diagnostic through powershell and tried updating all the usb port drivers. I'm waiting on a hub or 2 to arrive to make sure it isn't an incompatibility with the usb 3 ports (which is all the computer has). After that Ill schedule a computer tech to come and try to resolve the usb issue. But if anyone has any wonderful thoughts, I'd love to hear them!!
     
  6. KC3PGT

    KC3PGT Platinum Subscriber Platinum Subscriber QRZ Page

    Problem Solved!! All it took was using putting a USB 2 hub between my 991a and the new computer. This solution was suggested by the fellow at RT Systems and fully resolved the problem. Thanks very much to all!
     
  7. G8FXC

    G8FXC XML Subscriber QRZ Page

    Hmmm, not obvious to me why that should solve it - but what the hell - you'll probably end up needing more USB ports than the computer has anyway, so the hub will eventually become necessary for that!

    Martin (G8FXC)
     
    PY2RAF and KC3PBI like this.
  8. KA9JLM

    KA9JLM Ham Member QRZ Page


    Cool Beans.

    USB 3 ports can cause problems when using a older USB 2 device.

    That is one reason many computers have a least 1 USB 2 port on them.

    Enjoy.
     

Share This Page