Xiegu G90 Unable to update firmware for head unit

Discussion in 'General Technical Questions and Answers' started by KE0CCI, Mar 22, 2021.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: QSOToday-1
ad: Left-3
ad: Left-2
ad: l-BCInc
ad: l-gcopper
ad: L-MFJ
  1. KE0CCI

    KE0CCI XML Subscriber QRZ Page

    Ran into an issue where the head unit wouldn't power on. One suggested solution I found on the Internet was to update the firmware. This worked fine for the base unit but for the head unit I get no response in TeraTerm.

    I tried doing the factory reset method of holding down Func key while powering up, but that had no effect either.

    Anyone know of anything else I can try to revive the head unit?
     
  2. K2TY

    K2TY Premium Subscriber QRZ Page

    I noticed with mine sometimes it will lock when updating the firmware. I had to physically remove the power (battery) then it behaved normally.
     
  3. KE0CCI

    KE0CCI XML Subscriber QRZ Page

    I did try completely removing power but that didn't help.
    Appears my firmware may be corrupt but I can find no way to reset it.
     
  4. K8XG

    K8XG XML Subscriber QRZ Page

    Make sure you check the 1K box in Tera Term
     
    OK1USU likes this.
  5. KM6NJQ

    KM6NJQ Ham Member QRZ Page

    What 1k box is that?
     
  6. K8XG

    K8XG XML Subscriber QRZ Page

    When you select to transfer the file on the bottom left side there is a Check Box you must select that says "1K" which means the block size to use.
    If you don't check that the firmware will be corrupted. Not to worry, just flash it again with the 1K check and all will be fine. Happened to me twice forgetting about that checkbox.
     
  7. W4NNF

    W4NNF XML Subscriber QRZ Page

    As for your original problem, a couple of folks I know have had problems with the connection between the rig and the control head.
     

Share This Page

ad: AbAuRe-1