ad: w5yi

XIEGU G90 HEAD UNIT NOT POWER ON

Discussion in 'General Technical Questions and Answers' started by K2TLX, Aug 20, 2020.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Subscribe
ad: l-BCInc
ad: l-gcopper
ad: Left-2
ad: L-MFJ
ad: Left-3
  1. K2TLX

    K2TLX XML Subscriber QRZ Page

    Hello And Greetings My Fellow Hams

    1) Powered On My Xiegu G90 And Was Done Messing Around On 80 M With It

    2 ) Turned Off Radio Via My DC SWITCH

    3) Went To Turn On Radio Again To Get On 80 M Net To Talk And Head Unit No Lighting UP At All ANd Screen No Powering On Also I see It Pulling Current But No Power On Head Unit

    ????

    Did It Just Die?

    Thank You For Help
     
    OK1USU likes this.
  2. WB2WIK

    WB2WIK Platinum Subscriber Platinum Subscriber QRZ Page

    Are you using the head separated from the radio body?
     
  3. K2TLX

    K2TLX XML Subscriber QRZ Page

    No it stilll attached when i power it on i called xiegu and amayon there are doing a one for one swap with me
     
  4. VA3NKA

    VA3NKA XML Subscriber QRZ Page

    Same here. Just happened. I think it was the CAT cable that froze the radio and after reboot, the head unit did not light up.
     
  5. YU2MBX

    YU2MBX Ham Member QRZ Page

    I have the same problem with my new Xiegu G90. Can not power on. Mic get power light up for a second. Any suggestion how to fix this problem
     
  6. KC3PBI

    KC3PBI XML Subscriber QRZ Page

    Disconnect the cat serial cable- that's the lower 3.5mm connector on the left side of the head.

    If that serial interface receives anything when the radio is booting, it interprets that as "press any key for firmware utility" and does that instead of booting up into the normal radio interface.

    If you disconnect the serial cable OR put some good ferrite beads on that cat cable, you can eliminate the noise causing the radio to think you are trying to reload firmware in serial terminal mode.
     
    KL7KN likes this.
  7. VA3NKA

    VA3NKA XML Subscriber QRZ Page

    I made it work by re-installing the firmware.
     
  8. W8DBC

    W8DBC XML Subscriber QRZ Page

    Thank you for posting this fix! I was able to just send the firmware for the display unit and it came back to life. You saved me a lot of trouble!
     
  9. F4HZT

    F4HZT Ham Member QRZ Page

    Hi,
    sorry for my bad english.
    Same with mine. I think it was the CAT cable that froze the radio and after reboot, the head unit did not light up too.
    Tried several techniques (F switch, PRE switch), and was able to send the firmware to the body and display unit, but the RTX remains the same.

    Display is blank (black), microphone lights up, little noise in the speaker. Nothing else.
     
  10. VA3NKA

    VA3NKA XML Subscriber QRZ Page

    It happens sometimes to me too.
    Unplug the CAT cable, turn the radio off from power supply wait a bit and then turn it back on.
    Plug the CAT cable last.

    IF it does not work update the update the firmware, then plug out the CAT and reboot.

    the CAT is what freezes it.
     
    OH8STN likes this.

Share This Page

ad: ProAudio-1