Xastir on Pi issue

Discussion in 'RFinderPi - Open Source radio interface based on R' started by N4LPK, Apr 17, 2017.

ad: L-HROutlet
ad: l-rl
ad: HRDLLC-2
ad: L-Geochron
ad: abrind-2
ad: L-MFJ
ad: MessiPaoloni-1
ad: Left-2
ad: Left-3
  1. N4LPK

    N4LPK Ham Member QRZ Page

    I have a Raspberry Pi 3 running Xastir with a Coastal Chip Works TNC on top of it. I cannot get it to connect to a server to load maps. I have tried noam.aprs2.net and rotate.aprs2.net to no avail. It either times out or fails in making the connection. I to this point have even reformatted the SD card and reinstalled the image but can't get it to work. I have another image that I can use with Xastir and it works. But this one is a bit more custom. I have the m/filter set at 150. My password is correct. I am using port 14580 which is the default port. I have rebooted my router for the ethernet and even changed cables twice to make sure I am getting a good connection. Anyone else have a clue what to do next. I did not do the custom image. I found it on a website.
  2. VE7KNL

    VE7KNL Ham Member QRZ Page

    I've played with Xastir on an Pi a bit and the only maps that I got to work are Online/OSL_tiled_mapnik.geo It should be listed in the Map Chooser. Deselect all others then select mapnik.
  3. K1OC

    K1OC XML Subscriber QRZ Page

    I had a similar problem and fixed it by changing the m/filter to a r/filter (radius around a fix point). I haven't investigated further to see why that fixed it, but it did. Btw, that's to get APRS reports to come in over the Internet. Loading the maps themselves is a different problem. I also selected Online/OSL_tiled_mapnik.geo, and that works just fine.

    The problem I'm having is that I can't get the TNC-Pi to start. I've double-checked all the additional configurations the TNC-Pi instructions say are required for the Pi 3 but it still doesn't work.
  4. K1OC

    K1OC XML Subscriber QRZ Page

  5. N4LPK

    N4LPK Ham Member QRZ Page

    For some reason I was using a downloaded image that another ham created. I could never get it to work. So I took the best things he had on his image and added them to my original image I had been using and now all is good. My original image used rotate.aprs2.net and worked. Thanks for the replies.

Share This Page

ad: elecraft