WSPR using WSJT-X and ICOM 7300 on MacOS

Discussion in 'Mac Ham Radio on macOS & iOS' started by 2E0JDJ, Mar 30, 2020.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: L-MFJ
ad: Left-3
ad: Left-2
ad: Subscribe
  1. 2E0JDJ

    2E0JDJ Ham Member QRZ Page

    Hi,

    I’m wanting to use WSPR to get an idea of my antennas effectiveness, I plan to use band hopping between 20m and 40m and would like to set it up to run for a day or two so I can get a decently rounded idea of how it is working.

    An issue I’m having at the moment is that when I leave it running it seems to stop transmitting (or receiving) after a little while. For the purposes of this I am interfacing directly with the 7300 rather than via RUMLogNG to simplify things.

    My Mac is set to not go to sleep, although I put the screen to sleep sometimes.

    Any help would be appreciated!
     
  2. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page


    Sounds like App Nap is kicking in. You can watch this on the Activity Monitor's energy tab. It may be worthwhile to leave WSJT-X running alongside Activity Monitor to see if it gets affected.

    App Nap can be turned off. A Google search will reveal how.
     
  3. WV8A

    WV8A Ham Member QRZ Page

    The "Get Info" pane (CMD-I) for an individual program will show a "Prevent App Nap" checkbox if it's an option.
    I'm only seeing this shown in Get Info for older, 32-bit apps.

    As Dave mentioned, there are command-line (Terminal) solutions to disable App Nap system-wide.

    I've also heard of, but not experienced, some USB hubs "sleeping" after a period of inactivity, to save power.

    Chuck
    WV8A
     
  4. 2E0JDJ

    2E0JDJ Ham Member QRZ Page

    Thanks for the suggestions!

    So I disabled App Nap completely and Gad it run successfully for a few hours, but then at about 01:30 UTC it just stopped running. When I checked it this morning the waterfall view had just stopped.

    Even after restarting WSJT-X it didn’t seem to be receiving audio and when I hit tune the radio transmitted but there was no tone. I also tried switching radio on and off to no avail. I’ll guess I’ll have to restart the machine, but I just can’t see why this is happening. I’m connecting via a cable straight into the back of the machine.
     

    Attached Files:

Share This Page