ad: M2Ant-1

WSJT-X V2.4 - Fatal Memory Error on Install

Discussion in 'Mac Ham Radio on macOS & iOS' started by KL0S, Jun 10, 2021.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: abrind-2
ad: Left-2
ad: MessiPaoloni-1
ad: L-Geochron
ad: HRDLLC-2
ad: L-MFJ
  1. KL0S

    KL0S XML Subscriber QRZ Page

    V2.2 has been stable for a long time...just tried to install V2.4 and although it will install into my Applications folder but it won't open and returns a "fatal memory error". Tried it with V2.5rc1 as well with the same result. I'm using OS 10.3 High Sierra which according to the notes should be ok. Anyone else having an issue?

    Thanks in advance!

    73 - Dino KLØS
     
  2. DL2RUM

    DL2RUM Ham Member QRZ Page

    See your downloaded installation files. There is a file named ReadMe.txt included. You should read this very carefully.
     
  3. KC3PBI

    KC3PBI Ham Member QRZ Page

    Have you done the shared memory size adjustment?

    This error is completely normal until you adjust this memory buffer via terminal. The instructions are included with the download.
     
  4. KL0S

    KL0S XML Subscriber QRZ Page

    Yep, done that years ago when I started out with WSJT...that's why V2.2.2 works FB but neither of the two new versions will, both with the same memory error. Obviously it has something to do with the build of the next two versions, 2.4 and 2.5rc1. Not my first rodeo here.
     
  5. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    2.4 runs just fine on my M1 Mini.

    Just FYI, if you've recently done an OS update, you may have to run the fix again. I'm sure you know that, but just in case.
     
    N8JSM likes this.
  6. KL0S

    KL0S XML Subscriber QRZ Page

    Wish that were true but this High Sierra install has be in place and stable for several years...what doesn't make sense is that 2.2.2 works FB but 2.4/2.5rc1 both do not.
     
  7. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Figured that was the case, but just wanted to double-check.

    At this point, I would suggest -- although I'm not really sure exactly what it would accomplish -- that you removed all WSJT-X installations from the Mac, backup and then remove the WSJT-X folder in your Library, reboot and try to install fresh. If that works, you can then copy your WSJT-X log data back into the folder so that you don't lose that. The line of thinking here is that perhaps something in that folder is causing an issue, although I think that it is unlikely.

    The ultimate solution may be to do a clean install of High Sierra and all of your applications, but that is an extreme solution that is not guaranteed to work either.

    Sorry I can't be of more help.
     
  8. N6YWU

    N6YWU Ham Member QRZ Page

    You can use Applications/Utilities/Console.app to locate your Macs crash logs. If you can find a crash log for wsjtx, those logs possibly indicate a hint at why the fatal memory error occured.
     
  9. KL0S

    KL0S XML Subscriber QRZ Page

    Well, turns out you were absolutely correct...even though I'd run the Terminal scripts eons ago and V2.2.2 was working fine when I checked the shmax value it was not correct. Once I re-ran the command line the shmax was correct and V2.4 works FB. I should have listened to you before but thought that only a OS update would impact on the setting. TNX! 73 - Dino KLØS
     
    N8JSM and K3DCW like this.
  10. KD4RAU

    KD4RAU Ham Member QRZ Page

    Trying to delete this message.
     

Share This Page