ad: KG5DTX-1

WSJT-X v1.8 crashing on Mac

Discussion in 'OS: Mac OS' started by K5ACL, Aug 3, 2017.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
  1. K5ACL

    K5ACL Premium Subscriber QRZ Page

    Was just using v1.8 last night fine, today when I go to try and use, WSJT-X tells me it can't connect to radio on my Mac, and when i try to go and make sure all the settings are right & test the CAT connection, the program just crashes. I've tried reinstalling the program, no dice. Switched to my Windows laptop, everything was fine w/ v1.8.

    Using a Kenwood TS-480SAT - Baud 57.6k - CAT for PTT using a serial to USB cable (w/ ftdi chip)
    Using a Rigblaster Advantage for the Soundcard - disconnected while I attempted to get the CAT connection going but no dice...
     
  2. K4YWZ

    K4YWZ XML Subscriber QRZ Page

    Have you rebooted the Mac? If not, do that twice in succession. Then start your radio. Then try starting WSJT-X.

    When you first installed WSJT-X, did you perform the step listed in the ReadMe to increase shared memory?

    Are you using a logging program on the Mac (like MacLoggerDX)? (If so - and if it's working - it confirms that your driver and cable connection are good).
     
  3. K5ACL

    K5ACL Premium Subscriber QRZ Page

    Yes I performed the shared memory increase procedure. I'll try the rebooting twice... it's weird because it was just working fine the night before... Always crashes right when i click Test CAT. Also having an issue with my time sync on the Mac... I have to open up the time settings every time I boot my computer up or wake it up from sleep in order to sync the time... even though the check box is marked to keep the time in sync automatically. When I click the lock to make changes, I can see the clock usually jump forward about 3-4 seconds everytime I do it. I am able to connect to the radio through MacLoggerDX, but leave it disconnected while WSJT-X is in use of course.
     
  4. K0PIR

    K0PIR XML Subscriber QRZ Page

    Did you find a solution?
     
    K5ACL likes this.
  5. K5ACL

    K5ACL Premium Subscriber QRZ Page

    Hey Rich, sry forgot to follow up!

    Yes, 'Bill' from the Yahoo group said my issue was only fixable by the new RC2 release (which hasn't been released publicly yet).

    So I tried it out, and sure enough, all was well after the new software! Apparently it was a hamlib issue of some sort. Hopefully they'll release it soon...

    -Johnny
     
    K0PIR likes this.
  6. AD0AR

    AD0AR Ham Member QRZ Page

    I can't get it to work on windows. Crashes immediately on startup... So I reverted back to the old 1.7 and now my freq window stays red and the dropdown box for freqs stays blank now. I have to dial in manually all freqs, even for wspr. Wiped the directory, same story....
     
  7. K0PIR

    K0PIR XML Subscriber QRZ Page

    That's what was happening on my iMac. I uninstalled it, reinstalled a old version, v1.4, moved onto v1.7 and now I'm at v1.8 (first rc). It's working on my iMac, but I still seem to have a problem with the USB Audio CODEC at startup, but it doesn't keep me from operating.

    Just today I went with the latest version of RUMLogNG and WSJT-X intergration with it, and it works FB. No problems at all.

    My Windows machine has not had any problems. I wonder what would happen if you started all over with v1.4?

    73's Rich
     
  8. K0PIR

    K0PIR XML Subscriber QRZ Page

    Thanks for the reply, that's good to know it's being addressed.

    73's
     
  9. AD0AR

    AD0AR Ham Member QRZ Page

    I ended up clearing the cache on the windows machine. It is under the appData in the user profile which is a hidden folder. After deleting it, all works great again.
     
    K0PIR likes this.
  10. K0PIR

    K0PIR XML Subscriber QRZ Page

    Good to know. I had a similar folder in my iMac under Library>Application Support.

    73
     

Share This Page