WSJT-X Raspberry Pi Operating SPLIT MODE

Discussion in 'Amateur Radio News' started by K0PIR, Jan 20, 2017.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Left-3
ad: L-MFJ
ad: Subscribe
ad: Left-2
  1. K0PIR

    K0PIR XML Subscriber QRZ Page

    I've been experimenting with the Raspberry Pi 3 and have WSJT-X running smoothly. Lots of contacts using just 5 watts. My rig is an Icom 7300 and it's working beautifully in split with the Icom 7300 set as rig.

    [​IMG]


    See the full article at ICOM 7300 WSJT-X RASPBERRY PI OPERATING SPLIT MODE
     
    DH7HS, KA1ULN, G6YZC and 1 other person like this.
  2. G6YZC

    G6YZC Ham Member QRZ Page

    Hi Rich,

    Just yesterday I was watching your video on WSJT-x and the Pi as we were discussing if it was possible to set up WSJT-x and a Pi3 as part of a 2 way uW JT4 beacon.WSJT would only be needed to take the RX audio from the U3S digi beacon and report what it hears to PSK Reporter. As I am not a Pi man I have a few questions and was wondering if you would possibly drop me an email so that we can discuss what is needed. Thank you paul N2EME g6yzc@msn.com
     
  3. WJ4U

    WJ4U Ham Member QRZ Page

    Just to be clear, your Icom radio is making the Qs here while the Rasberry Pi is acting as the soundcard, right?
     
  4. K0PIR

    K0PIR XML Subscriber QRZ Page

    Hi Bill,

    Great question. Actually WSJT-X is configured using the Icom 7300 USB Audio CODEC. So it's not the Pi, but the 7300 as the sound card. I just plugged the USB cable in from the 7300 and the Raspberry Pi did the rest. Nothing to install.

    This clip shows it around 3:35 :
    In that clip I'm using two cables, but only one is necessary. My current config only uses the USB cable.

    73,
    Rich, K0PIR
     
    K2NCC likes this.
  5. WM3M

    WM3M Ham Member QRZ Page

    Thanks for the info but I can not get it to work. When doing the search for the WSJT software the PI3 comes up with a different version. It seems to install fine but when I click on it in the audio menu nothing happens. The PI3 usage goes up to about 25 per cent so something is running but nothing on the monitor? Only way to get it to stop is reboot? I tried several times, and used various version of spelling for WSJT but no help? I also did full update of the PI3 before I started. Any suggestions would be appreciated.
    Thank you 73 Emory WM3M email wm3m73 at verizon dot net
     
  6. K0PIR

    K0PIR XML Subscriber QRZ Page

    Hi Emory,

    What version are you seeing? It does take a minute for mine to come up. The version I have is WSJT-X v1.7.0. When you search for the package in ADD/Remove Software search for WSJTX. If you search for WSJT it'll also come up with wsjt-9.7 and that's not the one to install.


    Here is another how-to I found on. It comes from WSPR.net: http://blog.marxy.org/2016/03/wspr-via-wsjtx-on-raspberry-pi-3.html
     
  7. WM3M

    WM3M Ham Member QRZ Page

    Rich, When I do the search for wsjt I get the wsjt-9.7 and wsjtx-1.1r3496-3. I installed both, and after awhile got both to work or at least load. I have not tried actually using them with a rig. Neither one has wspr, lots of other modes but no wspr which is the one I am looking for. I have done the search several times, same results. I also found the blog.marxy.org you mentioned and loaded it. I just can not seem to find one that has wspr?
    Thanks for your help 73
    Emory WM3M
     
  8. K0PIR

    K0PIR XML Subscriber QRZ Page

    E-mail sent.
     
  9. K0PIR

    K0PIR XML Subscriber QRZ Page

Share This Page