WSJT-X on Linux Mint

Discussion in 'Computers, Hardware, and Operating Systems' started by KG7FIU, Feb 14, 2021.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: abrind-2
ad: HRDLLC-2
ad: Left-3
ad: L-Geochron
ad: MessiPaoloni-1
ad: Left-2
  1. N7EKU

    N7EKU Ham Member QRZ Page

    Why are you downloading a deb package?

    wsjtx is right there in the package manager. I installed it in 30 seconds.

    73.
     
  2. KK4NSF

    KK4NSF Ham Member QRZ Page

    that is what we've all been told... I've seen that in print a number of times. But interestingly I just did a Win7 install this last week..... and it was activated, all of the security and service pack updates came through, and MS Security Essentials loaded and updated with the latest virus definitions. SO it looks to me like MS is full of BS! The servers are not yet off-line.

    Now... about Win7: yes, I did install it instead of Linux. BUT that is only to run SDRplay software.... which as we all know is still undeveloped for Linux. So yes! I did it! BUT only this one time... and I didn't like it, or inhale! :D
     
  3. W5UAA

    W5UAA Ham Member QRZ Page

    Really? Hmm... Last time I tried loading up a fresh install of Win 7 was about 10 months ago. Tried the original key and it said I had to dial a 1-800 number. So I dialed it and input the new key given to me by the mechanical voice over the phone. It took it and continued on. And then all I got was an undefined error when ever an update download started. That was about 7 days after the announcement that Windows 7 extended support was discontinued except for those who start to pay for it.

    I've been 100% Fedora Linux since then. If I can think of a reason to load up Win 7 again, I'll try it again.
     
  4. KK4NSF

    KK4NSF Ham Member QRZ Page

    yep.... there is a trick to the current activate / update thing with Win 7. The Activation and Updates only work if you first install Service Pack 1. there are a few webaites that show you how to do it.... then after that, it all works like a charm. Google "Windows 7 won't update" and you'll find a page that will walk you through the process.
     
  5. W5UAA

    W5UAA Ham Member QRZ Page

    Ya, I tried that at the time. I also have SP2 and the final "rollup" (informally known as SP3) on disk. SP1 loaded but I was still getting some numeric error from the update server that didn't google and SP2 wouldn't load (probably without some updates to my SP1).

    Not a problem. I can't think of any reason why I need any Windows OS any more. I can do everything I want to do under Fedora. I find that I'm even forgetting how to navigate around the Windows control panel and forgetting some important *.msc and *.exe run commands. And I find I'm starting to get really comfortable with Fedora Linux. The scars from the shackles around my ankles from Microsoft Windows are finally healing.

    “Free at last, Free at last, Thank God almighty we are free at last.” (Martin Luther King, I Have a Dream)
     
    KK4NSF likes this.
  6. KK4NSF

    KK4NSF Ham Member QRZ Page

    Understood.... My guess is that MS's servers are partially operable, partially inoperable.... based on some algorithm that only they know... OR they are just stupid, and don't know what is and is not working within their own system.

    Either way, I'm with you on the FREE AT LAST thing. The feeling of being out from under MS's control is indeed refreshing!
     
    KD0KZE and W5UAA like this.
  7. WB8DD

    WB8DD Ham Member QRZ Page

    WSJT-X version 2.5.0 (Flatpak) is now available from the Software Manager. Installed without problems on Linux Mint 19.3.

    Only had to copy/paste the log file from the older version into the 2.5 version. Also had to reset the audio settings. Besides that everything works fine.
     
  8. KG7FIU

    KG7FIU Ham Member QRZ Page

    Update: came back to this after a few months. Thanks to the dozens of people who responded. Haven't had time to review all these yet...

    Meanwhile, actually did get wsjt-x to install on Linux Mint 19.3 using the "Synaptic Package Manager" tool. Even seems to run. But looks like it's an old v 1.1 version of the program with JT9 + JT65. No FT8. Not exciting... Tried to refresh the list of packages to see if there's anything more recent -- but doesn't appear to be. Again, maybe I'm missing something...
     
  9. KG7FIU

    KG7FIU Ham Member QRZ Page

    OK, just happened to see this. That sounds good. Will try that. Thanks!
     
  10. WB8DD

    WB8DD Ham Member QRZ Page

    You might also check out JTDX, which I just came across. It is a non-contest version (fork?) of WSJT-X that supports FT8, FT4 and several other modes. Supports most Linux versions Debian, Ubuntu 20.04 64 Bit, 18.04 64 bit, 16.04 64 and 32 bit.

    https://www.jtdx.tech/en/

    It has some different little features and overall is a bit simpler to operate. It will highlight previously worked stations from your logbook and only those stations if you wish - nice. I've run both in receive simultaneously and JTDX seems to decode just a tad deeper. Since I'm not a contest operator, this is what I've been looking for. Good luck.
     

Share This Page