WSJT-X Not working w/ IC 7300

Discussion in 'Computers, Hardware, and Operating Systems' started by N8XTH, Oct 23, 2017.

ad: L-HROutlet
ad: l-rl
ad: l-assoc
ad: L-MFJ
ad: Left-3
ad: Subscribe
ad: Left-2
ad: MessiPaoloni-1
  1. N8XTH

    N8XTH Ham Member QRZ Page

    I'm beyond puzzled and after 90 minutes of playing around, I give up. My goal was to use the USB cable for both sound card and PTT functions.

    I have the RS-BA1 working great with the 7300, so I know my PC is communicating with the rig.

    When I try to set up WSJT-X on the new rig I keep getting "Rig Failure, Hamlib error: IO error while opening connection to rig"

    Any help would be appreciated.

    Settings on WSJT:

    CAT: IC7300
    Com Port: correct port (works with RSBA1)
    Baud rate: 115200
    Data Bits: 8
    Stop Bits: 2
    Handshake: None
    DTR/RTS- blank

    PTT: CAT
    Mode: Data
    Split: None

    [Cat test fails/turns red]


    Rig Settings:


    set--->connectors
    Data mod: USB

    connectors---> CI-V
    CIV Baud Rate: auto
    CIV Address: 94h (works with ba1)
    CIV Transcive: On
    CIV-USB remote trancieve address 00h
    cov output for ant: off
    civ usb port: unlnk from [remote]
    civ usb baud rate 115200
    civ usb echo back: off

    usb serial function: ci-v

    usb send: (not sure how to set. off/dtr/rts --- when i set to dtr rig keys up right away and will not unkey until I change setting)

    usb keying cw - off
    usb keying rtty - off
     
  2. KG7FIU

    KG7FIU Ham Member QRZ Page

    You say the "CAT test fails / turns red". So maybe part of the problem is that CAT is not set up properly.

    If you're using the same COM port that works for RS-BA1, that's good. Try using the same settings for baud/databits/stopbits, also if possible. An easy way to tell if your CAT is working is that when you change the freq in the freq. dropdown list in WSJT-X, your radio should change to frequency value selected. If it doesn't change when you change the freq value in the list, then the CAT is not tracking.

    Also you said that when you select the "DTR" setting on "usb send" your radio keys up and stays keyed.
    I don't know about how things work on the 7300, but on my (Yaesu) radio, I had to set up the VOX / data circuit to work with WSJT-X. The transmit is keyed using the VOX circuitry. Perhaps you could handle keying the XMIT of the 7300 thru VOX, even though it may not be the most elegant solution.
     
    N8XTH likes this.
  3. KG5THG

    KG5THG XML Subscriber QRZ Page

    It appears that rs-ba1 takes ownership of the comport and this is keeping wsjt-x from gaining access when you start it. Take a look at https://ic7300.wordpress.com/ in the section for rs-ba1 remote software.
     
    N8XTH likes this.
  4. N8XTH

    N8XTH Ham Member QRZ Page

    Thank you both. Now I have some stuff to work with after work tonight!
     
  5. N8XTH

    N8XTH Ham Member QRZ Page

    Ugh so I tried to mimic the setting with no luck. Also e-mailed Icom tech support and of course their answer, blame WSJT and don't use BA1 and WSJT at the same time. Even trying what they suggested, nothing. UGH.

    I'm usually so very good at troubleshooting stuff like this. I'm beyond frustrated.
     
    Last edited: Oct 24, 2017
  6. N8XTH

    N8XTH Ham Member QRZ Page

    Hmmm.....nowI changed a setting and the radio is keying when you hit "test cat" but it still fails with the red button. getting closer LOL
     
  7. KG5THG

    KG5THG XML Subscriber QRZ Page

    These are the comport drivers I use

    https://www.icom.co.jp/world/support/download/firm/IC-7600/usb1_20/

    My rig setting that are different from yours

    connectors---> CI-V
    CIV Transcive: On ---> Mine is off
    cov output for ant: off ---> Mine is On
    civ usb port: unlnk from [remote] ---> Mine is Link to [REMOTE]
    civ usb baud rate 115200 ---> Mine is Auto and is also grayed out.


    usb send: (not sure how to set. off/dtr/rts --- when i set to dtr rig keys up right away and will not unkey until I change setting) ---> Mine is set to RTS

    usb keying cw - off ---> Mine is DTR
    usb keying rtty - off ---> Mine is DTR

    Below is a screen shot of the radio screen. I'm wondering what what happen of rs-ba1 was uninstalled and then try wsjt-x with the above comport drivers. I also use fildigi,filrig, and hrd 6 with no issues.

    wsjt-x-radio.jpg
     
  8. N8XTH

    N8XTH Ham Member QRZ Page

    I appreciate this so much. Sadly, I tried everything you suggested and still NOTHING. UGH

    (I also have the newest drivers installed)
     
  9. KG5THG

    KG5THG XML Subscriber QRZ Page

    I tried something for the heck of it and I changed my baud rate from 9600 to 115200 and wsjt-x wasn't going to have any part of it. It died in various ways and once got the red "test cat". Even though the option for ci-v baud rate appears to be "grayed" I can change it. It was when I went from "auto" to 115200 that I got the red "test cat" in wsjt-x. Any other combination just locked up the application. I would try ci-v baud rate set to auto and wsjt-x at 9600 just to see if there is some oddity about the "baud" rate and the usb driver as far was wsjt-x is concerned.
     
  10. N8XTH

    N8XTH Ham Member QRZ Page

    excellent observation. I've already shut my rig down for the night. I'll have to try it tomorrow.

    THANK YOU!!!!
     

Share This Page

ad: UR5CDX-1