WSJT-X not launching on Ubuntu MATE any longer

Discussion in 'Amateur Radio Software' started by VE3GZB, Sep 23, 2018.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: Subscribe
ad: Left-3
ad: L-MFJ
ad: abrind-2
  1. VE3GZB

    VE3GZB Ham Member QRZ Page

    I've been away from the radio and small single-board computer for a few days now. The computer takes so little power I can leave it on 24/7. Perhaps a software upgrade snuck in when I wasn't looking?

    So I'm trying to launch WSJT-X just now and nothing happens. FLDIGI works just fine, the hardware can still talk to the radio as it should, so the problem seems to be isolated to WSJT-X.

    I tried to launch WSJT-X via command-line to see any error messages and this is what I got:

    "~$ wsjtx
    MESA-LOADER: failed to retrieve device information
    libEGL warning: DRI2: failed to open exynos (search paths /usr/lib/arm-linux-gnueabihf/dri:${ORIGIN}/dri:/usr/lib/dri)
    ALSA lib pcm_dmix.c:990:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
    ALSA lib pcm_dsnoop.c:556:(snd_pcm_dsnoop_open) The dsnoop plugin supports only capture stream
    ALSA lib pcm_dsnoop.c:556:(snd_pcm_dsnoop_open) The dsnoop plugin supports only capture stream
    18-09-23T00:53:30.799Z: Unable to find an X11 visual which matches EGL config 1
    Segmentation fault"

    Thinking that perhaps some little thing in the whole package got altered I tried to fully remove and reinstall WSJT-X but to no avail, the same error occurs.

    Has anyone else seen this and if so, how did you resolve it?

    73s, geo VE3GZB

    Screenshot at 2018-09-22 20-56-40.png
  2. KP4SX

    KP4SX Premium Subscriber QRZ Page

    Did you try a reboot? :)
  3. VE3GZB

    VE3GZB Ham Member QRZ Page

    Yes, not just a reboot but a shutdown and restart. No change.
  4. VE3GZB

    VE3GZB Ham Member QRZ Page

    Trying to contact the WSJT-X mailing list was entirely useless, they wouldn't even accept my inquiry because I didn't belong to their club.

    Fortunately I kept a backup image from when I initially set everything up the way I needed, so I removed the memory card from the single board computer and reloaded the initial image. WSJT-X is working properly now.

    I just have to make sure that they system never downloads any updates or else I'll be stuck again.

    Computers, a love-hate relationship.

    73s geo VE3GZB
  5. DJ0ABR

    DJ0ABR XML Subscriber QRZ Page

    same problem here. EGL not found.
    Any solution yet ?

    73s de DJ0ABR
  6. VE3GZB

    VE3GZB Ham Member QRZ Page

    Yea, I replaced the single board computer with a compact desktop Lenovo running Winblows 10.

    Nobody from the WSJT community even wanted to hear my email and I doubt anyone in the Odroid community would understand what WSJT is.

  7. KI7PNG

    KI7PNG Ham Member QRZ Page

    I'm just setting up a my first station and getting this digital mode deal going. I noticed with FLDIGI I can't see any of the radio buttons on the configuration pages. Or, at best they are so weak and gray you can't be sure what's on and off. I bet it's a GTK or TK rendering deal on the screen with the MATE desktop - but that's just a guess.
    This is on linux running Debian stretch. WSJT-X doesn't have the problem for some reason. The only work around I found for now was to log out and back on using one of the GNOME 'classic' or other desktops, and then when I looked at these config pages in FLDIGI all is well. So I do that to setup, then when done go back to the MATE desktop since i prefer it so much over the GNOME flavors. Give it a shot if you haven't fixed your's yet.
    VE3GZB likes this.
  8. KI7PNG

    KI7PNG Ham Member QRZ Page

    Sorry I wasn't any help for your troubles VE3GZB, but I just found an answer to my problem with fldigi, you can change from gtk+ under the UI / General tabs and select 'base' or 'plastic' instead of the gtk+ default. Now all radio buttons show when clicked. Since the gtk+ rendering still looks better to me, I'll probably change it back after I get my config all dialed in. It's a sprint, not a marathon, right? lol.. 73
    VE3GZB likes this.
  9. VE3GZB

    VE3GZB Ham Member QRZ Page

  10. NC7U

    NC7U XML Subscriber QRZ Page

    Same issue here, WSJT-X on Mint 18 worked until a few days ago. Thought it may have something to do with the newer V2.0 just released. I cannot load the dependency "libc" v2.27 or greater as Mint is satisfied with v2.23.
    Back to RTTY until I find a fix.

Share This Page