WSJT-X not launching on Ubuntu MATE any longer

Discussion in 'Amateur Radio Software' started by VE3GZB, Sep 23, 2018.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: L-MFJ
ad: MessiPaoloni-1
ad: Left-3
ad: l-assoc
ad: Left-2
  1. VE3GZB

    VE3GZB Ham Member QRZ Page

    I've been away from the radio and small single-board computer for a few days now. The computer takes so little power I can leave it on 24/7. Perhaps a software upgrade snuck in when I wasn't looking?

    So I'm trying to launch WSJT-X just now and nothing happens. FLDIGI works just fine, the hardware can still talk to the radio as it should, so the problem seems to be isolated to WSJT-X.

    I tried to launch WSJT-X via command-line to see any error messages and this is what I got:

    "~$ wsjtx
    MESA-LOADER: failed to retrieve device information
    libEGL warning: DRI2: failed to open exynos (search paths /usr/lib/arm-linux-gnueabihf/dri:${ORIGIN}/dri:/usr/lib/dri)
    ALSA lib pcm_dmix.c:990:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
    ALSA lib pcm_dsnoop.c:556:(snd_pcm_dsnoop_open) The dsnoop plugin supports only capture stream
    ALSA lib pcm_dsnoop.c:556:(snd_pcm_dsnoop_open) The dsnoop plugin supports only capture stream
    18-09-23T00:53:30.799Z: Unable to find an X11 visual which matches EGL config 1
    Segmentation fault"

    Thinking that perhaps some little thing in the whole package got altered I tried to fully remove and reinstall WSJT-X but to no avail, the same error occurs.

    Has anyone else seen this and if so, how did you resolve it?

    73s, geo VE3GZB

    Screenshot at 2018-09-22 20-56-40.png
     
  2. KP4SX

    KP4SX Subscriber QRZ Page

    Did you try a reboot? :)
     
  3. VE3GZB

    VE3GZB Ham Member QRZ Page

    Yes, not just a reboot but a shutdown and restart. No change.
     
  4. VE3GZB

    VE3GZB Ham Member QRZ Page

    Trying to contact the WSJT-X mailing list was entirely useless, they wouldn't even accept my inquiry because I didn't belong to their club.

    Fortunately I kept a backup image from when I initially set everything up the way I needed, so I removed the memory card from the single board computer and reloaded the initial image. WSJT-X is working properly now.

    I just have to make sure that they system never downloads any updates or else I'll be stuck again.

    Computers, a love-hate relationship.

    73s geo VE3GZB
     
  5. DJ0ABR

    DJ0ABR XML Subscriber QRZ Page

    same problem here. EGL not found.
    Any solution yet ?

    73s de DJ0ABR
     
  6. VE3GZB

    VE3GZB Ham Member QRZ Page

    Yea, I replaced the single board computer with a compact desktop Lenovo running Winblows 10.

    Nobody from the WSJT community even wanted to hear my email and I doubt anyone in the Odroid community would understand what WSJT is.

    73s.
     

Share This Page