WSJT-X Configuration Issues

Discussion in 'Mac Ham Radio on macOS & iOS' started by K8GRR, May 17, 2016.

ad: L-HROutlet
ad: l-rl
ad: HRDLLC-2
ad: L-MFJ
ad: Left-2
ad: MessiPaoloni-1
ad: L-Geochron
ad: abrind-2
ad: Left-3
  1. K8GRR

    K8GRR Premium Subscriber QRZ Page

    Hi.

    I'm attempting to get WSJT-X to work with my Kenwood TS570D. I am brand new to JT65. So far I've only been able to get partial control of the TS570 sporadically (I'm experimenting with various configurations).

    When I post the Test button in the WSJT-X preferences Radio page, I'm getting the following message fairly consistently.

    Hamlib error: Communication timed out while getting currentVFO

    I have the WSJT-X audio settings set to Input "Mono" output "Both" and I have the iMac Audio Midi audio in and out settings set at 2 channel 16 bit integer.

    I'm able to control the radio in PSK31 via FLDIGI and FLRIG - but not so far in WSJT-X.

    Any help would be much appreciated.

    Thanks,

    Brian K8GRR
     
  2. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Perhaps someone with a 570D will chime in here, but it sounds like a configuration error somewhere or like some other program has control of the COM port. What are you using to connect the Mac to the rig; an interface of some kind or a simple USB-Serial adapter?

    1) Make sure all other applications that may access the COM port are closed.

    2) Make sure your baud rate matches what your rig is set for.

    3) Make sure your device name is correct. If the COM port device has both a tty.xxx and a cu.xxx variant, try the other.

    Are you using a Mac logbook program? If so, which one. You could configure JT-Bridge to work with MacLoggerDX, RUMlogNG or Aether, allowing them to have control of the rig and setting WSJT-X to work with JT-Bridge as a -- well, as a bridge. Besides, that would also give you access to all of the great features of JT-Bridge as well.
     
  3. K8GRR

    K8GRR Premium Subscriber QRZ Page

    Thanks. I've made sure that all potentially competing programs are closed, baud rate is correct and the com port. I have been able to get the Radio preferences page CAT Test button to turn green when clicked - but the pop up that should allow me to confirm correct settings does not appear. I am able to put the TS570 in Tune mode via the Radio preferences page so I know that there is some communication between WSJT-X and the radio.

    Any additional thoughts/suggestions would be appreciated.

    Brian K8GRR
     
  4. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    I'm not sure what pop up you're looking for. I'm not in front of my Mac right now, but as I recall if you hit Test CAT and it turns green, then all you need to do is hit "Ok" and close the preferences window. It will save the settings.
     

Share This Page