WSJT-X audio setup

Discussion in 'Amateur Radio Software' started by OK1TK, Dec 20, 2020.

ad: l-rl
ad: Subscribe
ad: L-MFJ
ad: abrind-2
ad: l-BCInc
ad: Left-2
ad: Left-3
  1. OK1TK

    OK1TK Ham Member QRZ Page

    Hello guys, I have probably something wrong in my Windows or WSJT-X setup and can't identify what could cause the follwong issue.

    Wiring
    Xiegu G90 ---> original miniDIN cable to CE-19 interface ---> Y stereo cable (3.5mm male Jack to 2x 3,5mm female) ---> 2x stereo extension cable 3.5mm jack male to male, one connected to the input of my USB external soundcard, second to the to the output ---> USB soundcard connected to my PC

    Xiegu G90 ---> original USB CAT control cable ---> PC

    SW
    Win10, FLRig, WSJT-X

    Issue
    My Windows10 Audio output device (the speaker icon on the task bar) must be switched to my external USB card connected as discribed above. If I switch my Win10 audio output to e.g. my 2.1 audio speakers or built-in LCD speakers the WSJT-X can still receive but can't transmitt resp. the radio is switched to transmitt but the output is 0 as I can see on the display of my rig.
    If the Win10 audio output is switched to external USB soundcard it work well and the output is the same lavele as it is set on my rig.
     
  2. KC3PBI

    KC3PBI XML Subscriber QRZ Page

    You need to set your WSJT to specifically use that external soundcard device rather than the "default system output"

    Then you can have all the other pc sound routed to your speakers, play music etc and still work radio.
     
  3. OK1TK

    OK1TK Ham Member QRZ Page

    This is what I set and have the same issue in WSJT-X and JTDX as well.

    File ---> Settings ---> Audio ---> Input: Mikrofon (3 - C-Media USB Audio Device); Output Reproduktory (3 - C-Media USB Audio Device); both set to mono

    Mikrofon = Mike
    Reproduktory = Speakers
     
  4. KC3PBI

    KC3PBI XML Subscriber QRZ Page

    Yes, looks like you have correct settings there.

    I can only guess that Windows is changing the audio routing on you- you're making one change, and it's doing two. I can't tell you why, but it sure looks like the problem is in the windows mixer.
     
  5. OK1TK

    OK1TK Ham Member QRZ Page

    Any idea how to check it, pls ?
     
  6. KC3PBI

    KC3PBI XML Subscriber QRZ Page

    Sorry mate, I don't know windows 10 well enough to give more detailed advice. Good luck!
     
  7. N3DT

    N3DT Ham Member QRZ Page

    In W10 go to settings/system/sound and scroll down to 'Sound Control Panel'. That opens a window that shows all your sound recording and playback devices, see the tabs at the top. Right click in an empty space and 'show disabled devices' and also 'show disconnected devices' so you can see everything. When you input audio to w10 one of the devices in recording should show green volume. And when you play audio or WSJT-X you should see playback green volume. You can also disable and enable all devices. You may also want to go to Settings/Privacy and go down to Microphone and 'Allow apps to access your microphone'. Make sure it is on. Below that you can manage what apps you want to access your microphone/line in.

    Somehow I created a shortcut to my desktop to the 'Sounds'. When something or W10 changes things and things don't work I can go in there easily and change them back. You'll have to remember what works.
     
  8. VK2JLS

    VK2JLS Ham Member QRZ Page

    Greetings all. My bugbear with Windows 7 audio is that to get stuff to work seems a black art at times. I have just installed an add-on called SoundSwitch, free off Github. Seems flexible and allows you to set your audio preferences for different programs, then control activating them by way of a hot key.

    My setup is simple. The F1 key sets my 'normal' sound requirements. To switch to my USB FT eight settings( needed with my Icom 7300) I just hit the F2 key. A banner displays which input / outputs are in use. It can be used for a number of different programs, but this is all I need. Works fine.
     
    WD4ELG likes this.
  9. OK1TK

    OK1TK Ham Member QRZ Page

    Thank you something happend when trying to set MRP4066 and it works now so I can play audio from my PC and WSJT-X works as well.
     
    WD4ELG likes this.

Share This Page