ad: elecraft

WSJT-X 2.0 and Raspberry Pi 3

Discussion in 'General Technical Questions and Answers' started by NJ1Q, Dec 20, 2018.

ad: L-HROutlet
ad: l-rl
ad: MessiPaoloni-1
ad: Left-2
ad: K5AB-Elect-1
ad: Subscribe
ad: L-MFJ
ad: Left-3
  1. NJ1Q

    NJ1Q Ham Member QRZ Page

    Hi folks,

    Has anyone had any success installing the latest version of WSJT-X on their Raspberry Pi. (I'm using Jessie.)

    I have version 1.9 installed and it works fine. But, when I try to install the latest version, all I get are errors, stating the package cannot be installed.

    It doesn't matter if I try to install it via GUI or terminal.

    As you know, according to Dr. Taylor's site, the latest version of WSJT-X must be used since it will not communicate with older versions. I shudder to think that those of us experimenting with the Pi and Ham Radio will be left out in the cold simply because of a version upgrade.

    I hope I'm just missing a step.

    Thanks.

    73,

    Joe, NJ1Q
     
  2. W7TCT

    W7TCT Premium Subscriber QRZ Page

    Likely not much help here but.... I am using stretch (Raspbian) on my 3b+ and all I did was download the .deb file (wsjtx_2.0.0_armhf.deb) from the website via Chromium. I then just double-clicked on the download and it installed. I had 1.9.1 on it and just loaded various RC versions as they were released. They each just overwrote the last version. (yes, I know. Who knows what orphaned libraries were left behind.)

    I did not use the Add/Remove software GUI nor Terminal so cannot address those methods.

    Try just opening the .deb file from your downloads folder....
     
  3. NJ1Q

    NJ1Q Ham Member QRZ Page

    Hi Tom,

    Thank you for replying to my post.

    I tried that earlier, but all I got was a "Failed to install file" error, with the text, "An unspecified transaction error has occurred."

    My favorite part is when it says, "More information is available in the detailed report." The problem is I can't find the detailed report. :)

    It's probably a small issue - maybe I didn't update something, even though I run updates/upgrades whenever I startup the Pi.

    The fact you were able to install it on your Pi3 with no difficulty is good to know; if reading between the lines, I get the feeling the WSJT-X site implies that some Linux installs require it be done by source. I'm not that well-versed in Linux. :)

    Thanks again.

    73,

    Joe, NJ1Q
     
  4. NE3R

    NE3R Ham Member QRZ Page

    does the raspberry pi 3 b+ have enough processing power for FT8?
     
  5. W7TCT

    W7TCT Premium Subscriber QRZ Page

    Re your upgrades, did you try dist-upgrade?

    sudo apt-get update && sudo apt-get dist-upgrade -y

    Just thought too, are you running the file via a root access login?
     
    Last edited: Dec 20, 2018
  6. W7TCT

    W7TCT Premium Subscriber QRZ Page

    yes. I use it exclusively and run VNC on it so I control it via my laptop. That is, I sit in my family room and do radio. :)

    Oh, I know it is "the death of ham radio" but there you are.
     
  7. NE3R

    NE3R Ham Member QRZ Page

    Awesome. I've been thinking about setting up a dedicated computer for the radio stuff, this might be just the thing.
     
    W7TCT likes this.
  8. VA3VF

    VA3VF Ham Member QRZ Page

    I used the RPi3 and 3+ for a time, but not with the new WSJT-X version 2.

    I could not use deep decoding on a full 3 kHz window in a busy segment. The RPi could not keep up with the number crunching. Well, it did eventually, but it was way past the end of the cycle, sometimes up to 6-7 seconds into the following cycle.
     
    W7TCT likes this.
  9. VE7BPB

    VE7BPB Ham Member QRZ Page

    You must change to the Stretch version. A friend just went through this and after much fooling around found that going to Stretch, installing 1.91 first, and then installing 2.0 made it all work.

    regards, Roy
     
    W7TCT likes this.
  10. W7TCT

    W7TCT Premium Subscriber QRZ Page

    Same here, had to go to Fast Decode. But, didn't see any difference re lost or garbled decodes.
     

Share This Page