Windows 10 Print to PDF has disappeared from my PC

Discussion in 'Computers, Hardware, and Operating Systems' started by KX4OM, May 8, 2018.

ad: L-HROutlet
ad: l-rl
ad: MessiPaoloni-1
ad: Left-3
ad: Left-2
ad: L-MFJ
ad: Subscribe
ad: l-assoc
  1. KX4OM

    KX4OM Ham Member QRZ Page

    If this has happened to you, and if you found a solution, please share. If you have gotten this message:

    The Handle is invalid when adding Microsoft Print to PDF

    then you, like me, have tried all of the usual help forums from Microsoft and the other resources from help sites and you probably have ended up on this Microsoft forum for tech experts in search of the answer:

    https://social.technet.microsoft.co...icrosoft-print-to-pdf?forum=win10itprogeneral

    The typical stabs at a fix:

    o Uninstall the driver for Print to PDF and reinstall it. [There is no such device listed in Device manager]

    o Create a new printer. [Dead end. Results ultimately in an error code that doesn't seem to relate to the problem. 0x800F0922]

    o This user tried all the things I did, and he is the one who ended up looking on the social.technet.microsoft.com forum above:
    ----------------------------------------------------------------------------------------------------
    1. Tried both DeviceCenterDiagnostic.diagcab and Printerdiagnostic10.diagcab
    2. Tried Andre Da Costa's article on how to add or reinstall the Microsoft PDF Printer
    3. Use the System File Checker tool to repair missing or corrupted system files.
    4. I have also tried to use DISM to Repair Windows 10 Image.

    The issue was originally posted on Microsoft community but no one can help to fix the issue. I hope someone in Technet forum can help.

    ----------------------------------------------------------------------------------------------------
    Apparently there is no solution other than reinstalling Windows from a Windows 10 ISO, which I don't have because I upgraded from Windows 7. One Microsoft rep said the equivalent of "your files will be right where you left them." Yeah, sure they will.

    I, like many others who have been trying to get Print to PDF back, or the related XPS Document Writer back after it disappeared, are twisting in the wind awaiting Microsoft's fix for a problem that they apparently can't understand.

    I did read the C:\Windows\Logs\CBS\CBS.log (1,809 lines in mine; one forum user uploaded his to Microsoft for analyis of his 3,000-plus lines. No answer.

    I'm about to pull the ripcord and parachute back to Linux Mint 18.3 and check back every week or so to see if Microsoft has met the task of coming up with what I think should be a simple problem. I do have a Macrium Reflect image from 3 weeks ago, but the problem will very likely reappear, doncha think?

    C'mon QRZ.com, somebody be a hero!

    Ted, KX4OM
     
  2. K6CLS

    K6CLS Ham Member QRZ Page

    Depending on what you want to print to PDF, Libre Office has it built in, and supports many file formats.
     
  3. KA9JLM

    KA9JLM Ham Member QRZ Page

    Don't download PDF files that contain a embedded virus would be my recommendation.

    Or do you have the Win 10 virus ? :rolleyes:

    Good Luck.
     
  4. KX4OM

    KX4OM Ham Member QRZ Page

    Don,
    The Print to PDF function is very useful for printing from Word documents to PDF (although I use Libre Office) and other types of files. It is really useful for printing a web page to PDF, like an article or a tutorial. That no longer works.

    I use Sumatra PDF as a PDF reader, and the Microsoft problem now won't allow me to print a page or range of pages an existing PDF to a file. Libre Office's export to PDF still works.

    Ctrl-p no longer works. The print to PDF does not show up in the list of printers. Print to Microsoft XPS Document Writer still shows up, but it throws an error when selected.

    From the number of people having this problem, it is widespread.

    Yeah, the Windows 10 virus. I use cygwin and rsync to back up my important files. Maybe I'll install the whole bash shell and try to figure it out that way. Proprietary Microsoft has no equivalent of man pages :)

    Ted, KX4OM
     
  5. KJ3N

    KJ3N Ham Member QRZ Page

    Is this another side effect of the April update?
     
  6. W7UUU

    W7UUU QRZ Lifetime Member #133 Volunteer Moderator Life Member Platinum Subscriber QRZ Page

    I agree with what's stated in other posts - must be something invasive your system has picked up. I'm on Win10 on all of my computers across home and office, all are kept fully updated, all work 100%, and all have "Print to Microsoft PDF" enabled and working.

    Have you tried a reinstall of the browser you're using?

    Dave
    W7UUU

    upload_2018-5-8_8-4-21.png
     

    Attached Files:

  7. KJ3N

    KJ3N Ham Member QRZ Page

    Answering my own question; apparently not. I'm on the April update and print to PDF is still an option.
     
  8. N4AAB

    N4AAB Subscriber QRZ Page

    I use bullzip pdf printer, it can also print to bmp, and png. I don't have to worry about changes MS makes.

    Here is the info page, and its available in a number of languages.

    http://www.bullzip.com/products/pdf/info.php
     
  9. KF5RRF

    KF5RRF Premium Subscriber QRZ Page

    @KX4OM

    If you haven't tried this, yet, you might try disabling that feature and re-enabling it. Turn it off, reboot, even it doesn't prompt you. Turn it back on.

    Control Panel -> Programs And Features -> Turn Windows features on or off
    upload_2018-5-8_12-31-29.png

    Good luck!
     
  10. KA9JLM

    KA9JLM Ham Member QRZ Page

    Sounds like PDF files will need to be signed and blessed by Microsoft in the near future.
     

Share This Page