What is the correct way to upgrade fldigi on Mac?

Discussion in 'OS: Mac OS' started by WA1RKT, Aug 8, 2019.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: MessiPaoloni-1
ad: L-MFJ
ad: Subscribe
ad: Left-2
  1. WA1RKT

    WA1RKT Ham Member QRZ Page

    Currently running fldigi version 4.0.18 on a MacBook Air High Sierra. All is working correctly (with an occasional crash I haven't narrow down yet, but that's for a different thread).

    Is there a correct way (among all of the incorrect ways) to upgrade to the latest fldigi version (which I believe is 4.1.05)? Do I just download the new and install over the old, or are there more steps that are needed like perhaps uninstalling the old first?

    (Decades of experience with computers but only about a year with Macs, so I'm still new to some of the install/upgrade/uninstall procedures for Mac applications.)

    Thanks...

    Rick WA1RKT
    Londonderry, NH
    Catch me on 14.300 MHz Intercon / MMSN most days
     
  2. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Download the latest version, drag the program to your Applications folder. Launch. It won't overwrite the old program as they'll have different version numbers. You will need to reauthorize firewall access for it, but otherwise doing the upgrade is painless.
     
  3. WA1RKT

    WA1RKT Ham Member QRZ Page

    Good afternoon Dave, thanks for the fast reply.

    So, after I finish the installation I will have two different versions of fldigi on my machine (the old and the new)?

    I will also be installing flrig to control my IC-746Pro. I haven't finished reading up on all of that but I'm assuming for the moment that flrig and fldigi interface with each other in some way. If both versions of fldigi are on my computer, how will flrig know which one to interface with?

    If I want to delete the old version first (unless there is a reason why I shouldn't do that), do I just hand-delete it from the Applications folder, or is there something else I need to do?

    Thanks...

    Rick WA1RKT
     
  4. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Flrig will work with both version of Fldigi with no issue.

    Once the new one is working, simply delete the old one from the Applications folder.
     

Share This Page