ad: w5yi

WHAT??? ANOTHER SB-220????!!!!!!!!!!!!!

Discussion in 'Amateur Radio Amplifiers' started by WA6MHZ, Jul 31, 2017.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
  1. WA6MHZ

    WA6MHZ Subscriber QRZ Page

    Just when U thought it was safe to come back into the forum (After the 106 page Journey on the SB-226);
    here is another one!! I promise this won't be stretched out that long!!!
    So I was at my favorite radio store and another Ham, who traveled along on the progress of the SB-226, decided I must be an EXPERT NOW on Heathkit SB-220s, so he commissioned me to fix up his.

    WELL it's not going to be that easy!!!

    When it was delivered to the Radio Hospital, it was indeed COMTOSE. Powering it on did nuttin!!

    All looked fine externally, no gorrilla mods or scratches. HOW HARD CAN IT BE????
    But what was inside would turn Most HAMS FACE WHITE AS A GHOST!!!!

    Lets have a look inside.
    It had a 220 plug on it and the Ham had plugged it into 220. NUTTIN!!!

    With Sues Suggestion on using the 2 ALTOID BOXES taped together, the cabinet came off easily.
    That would be the end of EASY!!!

    I found out in a hurry why nuttin happened!!
    20170731_110928.jpg
    UMMM...... THE AC WIRES from the PLUG are disconnected and taped together!!!!
    but then that SAVED A BIG FIRE!!!
    As we lookat the terminal strip, we see it is wired for 110VAC, not 220!!! But it hada 220 Plug on it.

    I queried the origin of the SB-220, and he said it was froma SILENT KEY SALE!!!
    NOW we know why the original owner was a SILENT KEY!!!
    BUT IT ONLY GETS WORSE FROM THERE!!
    (CONTINUED)
     
  2. WA6MHZ

    WA6MHZ Subscriber QRZ Page

    So the AUTOPSY continues
    When we looked at the FINAL COMPARTMENT after taking off the cover, we found this.!!!
    20170731_110855.jpg
    I had already removed the tubes, which were an unidentified brand
    20170731_120316.jpg
    what is interesting is there are NO PARASTIC CHOKES from the Plate coil to the tube caps!!!!!!!!!!!!

    HMMMM!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    But it only got worse from there!
    I took a look in the HV Compartment. Someone had changed out the 30K bleeders to 100Ks already. Unknown if the caps were changed though. They look original
    But someone had moused around with the DIODE BOARD and took out the Zener
    20170731_110850.jpg
    notice the red and black wires disconnected. THose went to the plate meter!!!
    I checked the plate meter and the movement is still good as is the Multifunction meter movement!! PHEW!! THose are UNOBTANIUM!!!
    BUT WHY would the HAM disconnect these????????
    It gets worse from here.
    (Continued)
     
    Last edited: Jul 31, 2017
  3. WA6MHZ

    WA6MHZ Subscriber QRZ Page

    I took a look at the Plate TUNING CAP. YIKES!!!!!
    20170731_115131.jpg

    20170731_115138.jpg
    lotta melted aluminum on those plates!!!
    But then we went to the TANK COIL!!!!
    20170731_115211.jpg
    here is the input circuit, kinda ratty

    20170731_115307.jpg

    I cant see any burned contacts on the Bandswitch, but I can't see very well in there
    20170731_115242.jpg

    I sent SUE all there Pix and she was just HORRIFIED!!!!!!!!
    SHE Highly advises AGAINST even touching this thing

    SO, the plan of action is:
    Test to see if the PLATE TRANSFORMER is still good. If OK, then she will bring home the TUBES and test them in her amp to see if they are any good.
    If either of those are bad, the AMP is good for scrap parts only!!!
    The caps probably need changing, and a new diode board installed, and a SOFT KEY and a SOFT START. That is just to make it work again.
    OH THEN he wants me to add the W7RY QSK MODS!!!

    I AM INDEED A GLUTTON FOR PUNISHMENT!!!
     

    Attached Files:

  4. WA7PRC

    WA7PRC Ham Member QRZ Page

    Too late -- you already started. :p
    I prefer glutton-free. :p
     
    W7UUU and K9ASE like this.
  5. WA6MHZ

    WA6MHZ Subscriber QRZ Page

    OH, and if that isn't ENOUGH!!!!,
    He brought along a 2nd AMP or me to fix!!!
    20170731_115944.jpg
    This one showed no HIGH VOLTAGE
    I was able to troubleshoot that to an OPEN 4.7M resistor! The 572Bs lit up and the HV is there, cuz I snapped it after shutdown with a big ZAP!!! it already has been recapped, but needs a SOFT KEY board. I keyed the KEY terminal to ground and the plate meter showed correct Idling current, so I imagine it works just fine.
    This one will be easy!!!
     
    NZ5F likes this.
  6. AF6LJ

    AF6LJ Premium Subscriber QRZ Page

    The Tune cap is toast
    The low band tank coil is toast.
    I wouldn't be surprised to find the output band switch isn't toast.
    None of the pictures show it very well.

    Graphite tubes....
    They out gas more than the other ones.
    You have to bring that up on a variac the first time you power it up with tubes in it on the CW position.

    I don't know................
    I wouldn't not of taken that project on.
    Looks like a $75.00 tech special to me.
     
    WN2C and K9ASE like this.
  7. WA7PRC

    WA7PRC Ham Member QRZ Page

    It may be savable... with some work.
    Carbon composition resistors are known to absorb moisture and drift high. The higher the nominal value, the greater they drift. Once upon a time, I found the three in my SB-220 had drifted high. One was just barely in tolerance. One was definitely out of tolerance. One was WAY out of tolerance.

    Replacements need to be rated to handle the HV (HK tried to fake it by using 1W resistors). Vishay BC Components #VR68000004704JAC00 (datasheeet) are rated to handle 10KV. Digi-Key has them as #VR68J4.7MCT-ND. Mouser doesn't appear to stock anything rated high enough. Buy enough for both of your amplifiers.
     
    AF6LJ likes this.
  8. AF6LJ

    AF6LJ Premium Subscriber QRZ Page

    We shall have to see, looks like it has been overdriven, certainly not tuned properly
     
  9. WA7PRC

    WA7PRC Ham Member QRZ Page

    Anything can be fixed (if you have enough time, money, and inclination). :)
     
    AF6LJ and K9ASE like this.
  10. WB2WIK

    WB2WIK Premium Subscriber QRZ Page

    $125/hour x 8 hours = $1000 repair job (on the SB-220).

    Plus parts.:)

    Otherwise I'd give it back to him and say "good luck.":p
     
    KK4YPQ, WG7X, AF6LJ and 2 others like this.

Share This Page