USB problems running WSJT-X on 2015 MacBook Pro

Discussion in 'Mac Ham Radio on macOS & iOS' started by EA3HOE, Dec 9, 2016.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: MessiPaoloni-1
ad: L-MFJ
ad: abrind-2
ad: Left-3
ad: L-Geochron
ad: HRDLLC-2
  1. KA9JLM

    KA9JLM Ham Member QRZ Page

    That is cool, I know that was a fix for Windows 10 too.

    Good work, Nice find. :)

  2. KN4GPT

    KN4GPT Platinum Subscriber Platinum Subscriber QRZ Page

    As an update to this;

    I have further found that the "real" problem with the audio into WSJT-X may be related to Stereo audio coming in / out of the USB Audio ports.

    In the Midi settings on OSX, I set the USB Audio parameters to 1 Channel, 48000Kbits for both in and out. Once I have changed this setting, OSX/WSJT-X works just fine, with or without the USB Hub. This setting appears to be automatically reset whenever you disconnect the cable, power down the radio etc. so it needs to be reset prior to each session.
    WF9F and WF7A like this.
  3. G4HUN

    G4HUN Ham Member QRZ Page

    I can confirm that adjusting the Midi settings as per KN4GPT post has worked for me, where all other suggestions failed.

    Late 2011 MBP running 10.13.6, and WSJT-X 2.0.1 into an Icom 7300.
    WF9F likes this.
  4. HJ3SUA

    HJ3SUA Ham Member QRZ Page

    Reviving this thread....

    Having the same problem with my Icom 7200, 2010 21" iMac, and macOS Sierra...
    I adjusted the Midi settings as KN4GPT recomended: "In the Midi settings on OSX, I set the USB Audio parameters to 1 Channel, 48000Kbits for both in and out"...
    It worked with: 1 ch 8-bit Integrer 48.0 kHz and 1 ch 16-bit Integrer 48.0 kHz.
    Finally after 4 months of struggling with my old iMac, and new to me ic7200, the problems has been solved!
  5. HK6T

    HK6T Ham Member QRZ Page

    Hi guys, what good information you have here.
  6. DG1SEK

    DG1SEK Ham Member QRZ Page

    I was fighting this for some hours too when running WSJTX or JTDX on a 2010 iMac 27" - was always loosing the USB audio interface. Especially after TXing. Inserting ferrites on the USB cable didn't fix the issue, but inserting a USB hub, as suggested by KN4GPT, fixed it for me.

Share This Page