USB problems running WSJT-X on 2015 MacBook Pro

Discussion in 'Mac Ham Radio on macOS & iOS' started by EA3HOE, Dec 9, 2016.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: L-MFJ
ad: HRDLLC-2
ad: Left-3
ad: MessiPaoloni-1
ad: Left-2
ad: L-Geochron
  1. EA3HOE

    EA3HOE Ham Member QRZ Page

  2. WD9ENB

    WD9ENB Ham Member QRZ Page

    Thanks, Ton. Unfortunately, it appears my problem was more related to audio rather than control much like what G8OFA described.
    You are running WSJT-X on the MBP without any issues of it reverting back to the built-in audio after a couple TX cycles?
  3. WV8A

    WV8A Ham Member QRZ Page

    I have all along been using a SignaLink USB audio interface (and earlier, a "pro audio" USB soundcard) while experiencing this issue. At seemingly random intervals, when going into Transmit mode, audio is directed (reverts) to the laptop's internal speaker and not to USB>soundcard>transceiver. I do have the computer's audio settings such that "normal" system or applications' sounds are only directed to the speakers, and USB for the digi mode software. That usually works as it should, except for when it decides not to!
  4. WD9ENB

    WD9ENB Ham Member QRZ Page

    I believe we are looking at two different issues. The original having to do with the control of the rig over USB and one having to do with the audio issue you mention (which I also have). WV8A, I believe I have found a solution to the audio problem. Sent you a PM (conversation) so as to not hijack the thread here any more than I already have.
  5. VK7DW

    VK7DW XML Subscriber QRZ Page

    Hi, I am experiencing the same issue with the Signalink USB audio randomly directed to the audio speakers on my iMac when transmitting. I was wondering if you came up with a solution, any help would be appreciated.
  6. WD9ENB

    WD9ENB Ham Member QRZ Page

    VK7DW, I found two solutions.

    First off, let me clarify which issue I'm talking about. The problem randomly starts whenever the USB device is used for both receive and transmit (whether it is a SignaLink or the built-in USB in the TS-590SG I was using). At some point (again, between a TX/RX cycle seemingly at random) it is as if the computer forgets where to send audio even though nothing has changed in the application's settings or in the system's audio settings. CAT functions still work, but the transmitted audio suddenly comes out of the built-in speakers instead of going to the USB out.

    Solution #1 - Continue using the USB interface for TX, but use another device (such as the built-in "line-in") for the RX. This had worked for me 100%. Yes, it is another cable and you'll have to figure out on your particular rig where you can get audio from such as the 13 pin ACC2 port on many Kenwoods. Also, maybe your Mac does not have a built-in line input. This does work, though, and is the method I went with.

    Solution #2 - Keep the USB interface for both TX and RX, but use a "virtual audio cable" application such as Loopback or SoundFlower as a middleman. As an example, in your app (be it WSJT-X, FLDigi, etc.) the RX audio device can be selected as your USB device just like normal. The TX device will have Loopback/SoundFlower's input selected. That input will be soft-wired to the TX component (output) of your USB device in the settings of the virtual audio cable. So, to the computer, it sees different things for the TX and RX, thus eliminating the issue.

    I tried solution #2 and it worked great with Loopback. Loopback is not free, though, if you want to use it without restrictions.
    I could not get SoundFlower to work right for me. I seem to remember it stopped being developed or something to that effect. JACK may be a usable alternative as well.

    Of course, it would be nice if everything worked like it was meant to, but what is the fun in that? :)
    Last edited: Aug 10, 2017
    KA2Y likes this.
  7. VK7DW

    VK7DW XML Subscriber QRZ Page


    Thanks so much for your detailed reply, it has helped me further understand how these programs and computers work and more importantly has fixed the problem.

    I downloaded Loopback and it has worked perfectly ever since, excellent stuff as it has been quite frustrating!!

  8. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    If you check your system's Console and look at the errors, you'll see a 1 or 2 millisecond disconnect/reconnect of the USB audio path when this takes place. These have been present in the last two or three OSX/macOS versions. That milliseconds long hiccup is sufficient to cause Fldigi and/or WSJT-X to lose the USB audio and then default back to the speakers.

    This works because Loopback is not as sensitive to those USB hiccups and remains connected to the USB audio across those millisecond long outages. Since WSJT-X/Fldigi see the same Loopback audio 100% of the time, things don't drop out.
  9. WD9ENB

    WD9ENB Ham Member QRZ Page

    Good to know the reasoning behind it. I had read somewhere else it has been plaguing OS X for a while.
    K3DCW likes this.
  10. KN4GPT

    KN4GPT Platinum Subscriber Platinum Subscriber QRZ Page

    Resurrecting old thread: Fighting with this for a couple days. Driver changes didn't work. Soundcloud sort of worked...but WSJT-X would simply stop listening to the port.

    I inserted a USB Hub/Switch into the mix. Problem gone. Now I have the USB cable from the FT-991a into the USB switch, into the MBPro, with WSJT-X set to "USB Audio" for in and out.
    DG1SEK and KA9JLM like this.

Share This Page