ad: UR5CDXcom-1

USB problems running WSJT-X on 2015 MacBook Pro

Discussion in 'OS: Mac OS' started by EA3HOE, Dec 9, 2016.

ad: L-HROutlet
ad: l-rl
ad: l-gcopper
ad: L-rfparts
ad: Subscribe
  1. EA3HOE

    EA3HOE Ham Member QRZ Page

    Hi all!

    This morning i posted the below message on the Apple forums. I guess i'd post it here as well, maybe someone can shine a light.

    Thanks in advance,

    Ton EA3HOE.

    ===
    I am a HAM and i am using my Early 2015 MBP for data communications. I seem to have a problem where the USB ports are not able to handle the traffic going from my software to the radio.

    I am using a USB cable running at 115200 between my radio and the MBP. You can see the behaviour in this video:

    In this video i first put a continuous tone on the USB port. The effect should be that the radio sends out this continuous tone on the air. However, as you can see in the video, the audio is interrupted and gets worse over time up to the point that the USB port is not receiving any data anymore and the transmit signal gets interrupted.

    I tried this with various USB cables and various different programs and the behaviour is the same with all.

    In the video you can also see that i am sending out a CW signal not using the MBP and that signal is clean.

    Why do i think it's the MBP? Because i tried a Late 2011 MBP running the same OS as my 2015 one (Sierra) this morning and that MBP doesn't have the issue.



    Any idea what has changed in the USB handling between 2011 and 2015?

    Any idea how i can manipulate the buffering if the USB port on the 2015 MBP?



    Thanks for your input,



    Ton.
    ===
     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    You may be able to turn the baud rate down, Then it may work.

    It does not need to be that fast.

    Good luck.
     
  3. EA3HOE

    EA3HOE Ham Member QRZ Page

    Turned it down to 19.200 and behaviour is still the same.

    Ton.
     
  4. WF7A

    WF7A Subscriber QRZ Page

    The only oddity I'm aware of with MBPs between those years is that sometimes I need to unplug the USB-connected device and plug it into another USB port on the MBP. For example, when booting an MBP from an external drive (connected by USB), sometimes the MBP doesn't "see" the drive connected to the rear-most USB port on the left side. However, if I unplug the drive then connect it to the front-most USB port on the left side, the MBP will see it.

    I haven't quite figured out why that happens, but it does. Try changing ports and see what happens.
     
  5. G8OFA

    G8OFA XML Subscriber QRZ Page

    Not a reply, but related. I have just installed WSJT-X on my iMac running OS-X Sierra, having reassigned memory as per the readme file. Connected to a TS-990S everything works for 2-4 transmission cycles and then the tx audio stream reverts to the internal speaker although CAT still switches the transceiver to tx. I believe others have seen this effect and wondered if any solutions had been found.
    73 Martin, G8OFA
     
  6. KW4EK

    KW4EK Premium Subscriber QRZ Page

    I guarantee your USB ports are more than adequate to handle RS-232 serial port data as they will typically be operating at either 12Mb/s (USB 1.1) or 48Mb/s (USB 2.0) depending upon the connected device (typically the 12Mb/s speed for RS-232 devices), so handling the lowly kilobits of RS-232 is barely a strain even if you had a dozen of them. However, selecting high serial speeds (such as your initial 115,200bp/s) can lead to corruption of the bits (on the serial port side, not USB side) due to buffer overflow or signal corruption as the buffers are quite small and signal integrity is not great at high data speeds. Given how little data CAT control needs to transport you could likely reduce things down to 4800bp/s and still more than exceed requirements, and those lower speeds reduce the risks of both buffer overflow and signal corruption. If your radio, and the software, support flow control (RTS/CTS, Xon/Xoff) then you could also enable such to reduce the risk of buffer overflows -- however some CAT control appropriates the RTS line for other purposes (e.g. PTT).

    But be aware that your issue may also relate to RF coupling back into the USB port and your PC if there is any stray RF on the radio or in your shack, particularly if you do not have an effective station ground to protect from such (and many do not). Stray RF coupling into the USB cable can corrupt the USB data or interfere with proper operation of either the USB port or the serial port dongle. Try installing a current balun at your antenna's feed point to help reduce such interference if you have not already done so. You could also install a USB galvanic isolator to break the electrical connection between the PC and radio via the USB cable to help keep RF out of the USB port and radio.

    You could also have issues with the software simply not keeping up during periods where there is a lot of higher priority kernel activity leading to delays (such as if a hard drive is failing and holding up the bus, which can cause momentary hangs, but other more mundane things as well). I can not offer any advice specific for Macs, but if running any other software or unnecessary services/daemons then close them down as well for starters to see if things improve.
     
  7. WV8A

    WV8A Ham Member QRZ Page

    Martin, Unfortunately this is not an uncommon issue and has been reported and commented on in a number of forums. I'm using MPPro (late 2011), 10.12.2 Sierra, FT-897D, and, like others, have had this intermittent problem going back a couple of years, with different apps and OS versions. I find it very frustrating having this occur when trying to operate, whether using fldigi or WSJTX. Makes digital QSOs and especially contesting an iffy proposition. I've done all the due diligence regarding grounding, RF-proofing, ferrites everywhere, etc.
    This seems to be a hardware or persistent internal OS audio problem for which nobody has proposed a solution that works.
    Chuck, WV8A
     
  8. KW4EK

    KW4EK Premium Subscriber QRZ Page

    I was interpreting this initially as the radio reverting back to internal speaker, but if it is the laptop side audio we are discussing then have either of you ever tried an external USB soundcard to see if such fixes your issue? They do not cost all that much these days and are widely available online (many choices for under $40). For digital modes it is generally better to run a dedicated soundcard anyhow so as to prevent system sounds from being broadcast and allowing normal use of laptop audio without needing to reconfigure the audio, so it may ultimately work out for the better if it solves either of your issues.

    Good luck!
     
  9. EA3HOE

    EA3HOE Ham Member QRZ Page

    Hi all!

    After talking to SiLabs they sent me an older driver which i installed and the issue disappeared. So in the end a driver issue after all.

    Ton EA3HOE.
     
    KA9JLM likes this.
  10. WD9ENB

    WD9ENB XML Subscriber QRZ Page

    Ton, which driver version did you end up using? Been fighting this issue for a while myself.
     

Share This Page

ad: M2Ant-1