USB Audio CODEC

Discussion in 'Computers, Hardware, and Operating Systems' started by NA6Y, Feb 28, 2020.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: QSOToday-1
ad: L-MFJ
ad: abrind-2
ad: Subscribe
ad: Left-3
  1. NA6Y

    NA6Y Premium Subscriber QRZ Page

    That's interesting. How did you get them back?
     
  2. KA0HCP

    KA0HCP XML Subscriber QRZ Page

    Hunt down the drivers and reload them. This latest loss has not been solved. My patience is short at the moment, and for some reason, the easy reload hasn't worked. The driver file seems to be corrupted. It doesn't work, I can't deleted despite using various utility programs, and didn't reload the two times I've tried.

    It will be an easy fix, when I find the right combination! ;)
     
  3. NA6Y

    NA6Y Premium Subscriber QRZ Page

    I know what you mean, I'm at my wits end here. Everything has been fine until recently. We had a bad electrical storm and everything went to hell. I got everything fixed but this. I'm about to back to stamp collecting hi hi. It will be an easy fix it's just not that easy to find out how!!

    John NA6Y
     
  4. K8HIT

    K8HIT Premium Subscriber QRZ Page

    Rolling back is a risk, most updates are for active exploits.

    When you turn off your rig, the #-USB Codec goes away, it should return when it powers back up. Each device that uses these will get their own number. My ic-7300 is 2-USB Codec. My 9700 is 3-USB Codec.

    You can uninstall a USB Codec in device manager by right clicking on it. A new one will be created and that could fix the problem.

    What do you see in device manager when you turn on and off your rig? Things should be changing.
     
  5. NA6Y

    NA6Y Premium Subscriber QRZ Page

    I don't see any obvious changes. What is it specifically that should change. There is no change if I look in 'Audio inputs and outputs'. 'Ports' shows my Silicone Labs Enhanced and Standard com ports but these don't change.
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    Try looking here.

    Control Panel\All Control Panel Items\Devices and Printers


    Look for the warning sign.

    upload_2020-3-1_9-4-25.png
     
    Last edited: Mar 1, 2020
  7. K8HIT

    K8HIT Premium Subscriber QRZ Page

    I mis-spoke early, turning off isn't enough, you must unplug the USB cable.


    The comm ports are what should change. You need to plug and unplug the cable from the computer.

    Device Manager, Ports (COMM & LPT), this will change even with radio turned off.

    Device Manager, Sound. Videos and game controllers, USB Audio Codec will show once for each of your radios.

    Device Manager, Audio Inputs and Outputs, will show the #- USB Audio Codec, as a microphone and a speaker.

    Control Panel, Hardware and Sound, you will see all of your #-USB Audio Codecs, Double Click on them and rename if you like. You still have to remember which number goes to which radio. Microphones will show under Recording.

    [​IMG]
     
    KA9JLM likes this.
  8. NA6Y

    NA6Y Premium Subscriber QRZ Page

    It appears what has happened is the lightning took out my USB port on the rig. It looks like I'm going to have to send it back to Yaesu. Even did a full factory reset, no joy.
     
  9. KA9JLM

    KA9JLM Ham Member QRZ Page

    Bummer.

    I have heard of that happening. Even with the antenna disconnected.

    Good Luck.
     
  10. K7RJB

    K7RJB Ham Member QRZ Page

    The VCP software binds itself to the first USB port that the radio is plugged into.
    Before shipping off your radio, Unplug the radio USB from the PC.
    Then remove the VCP software, reboot and re-install the VCP software.
    Then plug the radio USB back into the USB port on the PC that you will be using.
    You must always use that same physical port as the VCP software binds itself to that port.

    This drove me nuts for a week or two until this was explained.
     

Share This Page