TYT TH-9000D Locked Up

Discussion in 'General Technical Questions and Answers' started by AD7BF, Feb 29, 2016.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: abrind-2
ad: L-MFJ
ad: Left-3
ad: Subscribe
  1. AE5DX

    AE5DX Premium Subscriber QRZ Page

    I like this idea, it's quick and you got nothing to lose at this point.

    Push in and hold a different combo of 2-3 buttons while powering on. Worth a try, if you haven't already.

    I have 2 of these rigs and so far, so good. One was mobile for a couple years.
  2. AD7BF

    AD7BF Ham Member QRZ Page

    I did try shorting the power leads and coming back a couple of days later and powering it up again. No change - display still scrambled.
  3. AD7BF

    AD7BF Ham Member QRZ Page

    Tried that too. I managed to get one segment on one of the scrambled characters on the display to change and I managed to get it to change back later but everything is still scrambled either way.
  4. KM4BLG

    KM4BLG Ham Member QRZ Page

    In reality, removing the power while the radio is on shouldn't matter unless it was writing to memory when you did it. Which is usually not occurring when you are turning it off. I would look in the manual. There might be a reset process that would involve holding certain buttons while powering it on.
  5. KC9UDX

    KC9UDX Platinum Subscriber Platinum Subscriber Life Member QRZ Page

    It should never even be writing to memory that would matter at power down unless it's doing a firmware update.
    KM4BLG likes this.
  6. AD7BF

    AD7BF Ham Member QRZ Page

    True, but that seems to be what happened. I've had this happen with other radios too but a simple reset fixed it. Unfortunately, in order to do a reset on this partucular radio, you need to wade through menus and that requires a readable display. Kinda dumb, eh?
  7. KM4BLG

    KM4BLG Ham Member QRZ Page

    I agree. Although this is par for the course with Chinese radios. A lot of the higher dollar radios have some sort of mechanical reset (reset button to be pressed with paper clip, key combo, etc). The only other thing I can suggest is to remove all power from it and let it sit a few days. Maybe something will change after the capacitors have a chance to drain. Unlikely this will fix it, but at this point, it sounds like your only option other than sending it back or replacing it.
  8. KC9UDX

    KC9UDX Platinum Subscriber Platinum Subscriber Life Member QRZ Page

    It works be worthwhile to open it and discharge all capacitors and disconnect any batteries there might be.

    Unfortunately these things never come with standard parts nor accurate schematics; otherwise it may be possible to force a reset.
  9. W4FBI

    W4FBI Ham Member QRZ Page

    If I'm not mistaken, all Chinese radios have no Service Manual. If they break, you are out of luck. I've had the occasion to try to repair several. Never found any service manual for any of them.

    My .02
  10. TA5S

    TA5S Ham Member QRZ Page

    the same radio I removed the same problem we had in the slave power was off while the sockets when installing the device returned to its normal state , but the head cpu in part the error occurred that cpu -brand models on I could not find not get something from nothing device reads writes , if not only sound and output is working normally cpu change will be okay scheme ran across the track did not find the name of the device will operate 73 TA2SU

Share This Page