TS-940SAT Questions

Discussion in 'Amateur Radio Equipment Reviews' started by WB9BXT, Apr 17, 2020.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: Left-2
ad: abrind-2
ad: Left-3
  1. WB9BXT

    WB9BXT Ham Member QRZ Page

    I have a high serial number (12 mil) TS-940 that I just acquired and I have two questions ....

    1. The tuning rate is 3 KHz per revolution, not the 10 KHz that the manual states, and it doesn't change no matter how fast I spin the dial....

    2. Only every other band switch push button works....3.5 MHz, 10 MHz, 18 MHz, 24.5 MHz, and 29.0 MHz.

    I have reset the microprocessor, but no change....

    Any ideas?

    Thanks, and 73....

    Roger, WB9BXT.
     
  2. G3YRO

    G3YRO Ham Member QRZ Page

    You're more likely to get help if you post in the right section . .

    You want
    Radio Circuits, Repair & Performance

    But it sounds like you have a fault on your Digital Board

    Roger G3YRO
     
  3. W1GCI

    W1GCI Ham Member QRZ Page

    Connector 8 on the Digital B board receives the encoded lines from the switch board. Line B0 is the one associated with the bands that don't work. So, the wire is broken or the contact on the push button board or the Digital B board is making a bad connection. Whichever the case, this is likely your problem. As for the dial speed, I have a variable speed option/hack in one of my 940s. It works really good but it does vary with rotational speed.

    Arnie -W1GCI
     

Share This Page