ad: hrd-2

TS-2000 firmware+com port communication issues

Discussion in 'Radio Circuits, Repair & Performance' started by KC8QVO, Aug 13, 2020.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: L-MFJ
ad: Subscribe
ad: Left-2
ad: Left-3
  1. KC8QVO

    KC8QVO Ham Member QRZ Page

    Your question has a complicated answer. I'll try and uncomplicate it.

    This rig has had a history of back and forth to Kenwood for diag and repair. I am not sure of what the extent of it was, exactly. During those visits for repair it ended up on 1.08 firmware. As to whether or not it was working 100% after the visits, I am not sure.

    At the moment some of what I am after is giving the rig some running through of its paces to see how it is behaving. There were concerns of the output power level and receive sensitivity. So those are the two odd behaviors at the start of my looking the rig over.

    As best I could tell - the output power is fine. I am getting upwards of 98 watts on the service monitor on 2m, and that was the problematic band (we're thinking the low power that was seen could possibly have something to do with the power supply and interference from the 2m frequency, it runs pretty much 100 watts on all lower bands just not 2m). On my Astron VS-35M it is running about 98 watts on 2m - no problem.

    What has happened that I have seen is the receive drops from full scale down to S5 quite regularly.

    My train of thought was to try tuning the receive gain/sensitivity in the Adjustment Firmware (service software). I have fixed other receivers that way before - I can't explain exactly why, but my theory is due to the signal coming out of the processor/controller where that signal is sent from getting "stuck". By adjusting way out of spec and then calibrating back in it gets things lined up again. I don't know if that will fix this receiver - but it is worth a shot and there isn't anything I can screw up with the ability to align the rig already, so I am not afraid of throwing the rig out of whack with an Adjustment setting (in fact, quite the opposite - I want to throw it out of whack - then bring it back to calibrated).

    Before I got the Adjustment firmware loaded on the rig I backed everything up (menus, memory channels) in several files - 1 each for the memory control program and the service software program on 2 computers (4 files total).

    Then I put 1.12 firmware on the rig. This was, again, a direct update from 1.08 - not stepped.

    So to answer your question - Was the rig operating correctly prior to the firmware update? No. What I can see thus far is the receive signal strength on 2m would tank from full scale (pegged S meter) to S5. This is with the preamp on. The steps I was working through to fix that concern was to update firmware then get to the Adjustment/service software. When I got to the 1.12 firmware on the rig is when I ran in to the stuck PTT and the send button wouldn't release. So I tried back-dating the firmware to 1.08 again and that is where this thread is. I lost communication with the rig and the computers (both computers - same issue as I described earlier).

    To read in to your question deeper - Was the serial communication on the rig working correctly prior to the firmware update? Yes. That is how I saved the 4 files and how I was able to get from 1.08 to 1.12.
     
  2. KC8QVO

    KC8QVO Ham Member QRZ Page

    That is a valid thought, however also bear in mind that the voice synthesizer is not working at the moment either - there is no voice announcing of settings/frequencies. So for both the synthesizer and the serial comm components to take a dump simultaneously during the same "event" is a bit suspicious.

    As I'm thinking through the above - I am wondering, perhaps, if there is a protection fuse that sits between supply voltage to both the ADM and the voice synth.... I haven't had a chance to dig through the schematic, I've had a busy day and am just laying down for the night. We'll see what the next day or so brings.
     
  3. VE1IC

    VE1IC Ham Member QRZ Page

    Well, that sux balls... If the FW is buggered up, I’d see if I could find another TS2000, take out the flash IC that has the firmware on it, copy it with a USB programmer like a TL866ii or RT809h, save the dump file, reprogram my chip with that dump, put that back in my radio and see where I stand after that. Unless Kenwood has a factory flash / recovery software of some sort, or do they Programm it maybe through a TTL? I mean some how these radios need to be programmed at the factory.
    That gives me a second idea: Since the RS232 is serial, the data before that IC is Logic level. So check the RS232 side of the IC and also check the TTL side. There are USB to TTL converters cheap to be had. Maybe also look for a factory programming port. Checking things around the RS232 you are going to need an Oscilloscope. You are in a tough spot. Remember, if you see some life on the RS232 or TTL line from the radio to the computer, with the switch in programming mode and turn on the radio, she isn’t dead. Let’s hope the RS232 IC is dead and after an replacement, the radio loads FW from their upgrade tool, but as mentioned before: there are other ways to program the flash chip, but you need a dump file.
     
  4. KA5IPF

    KA5IPF Ham Member QRZ Page

    Check the RS232 IC. As a note. Alignment, either thru diddle sticks or software, does not fix a hard fault which you had.

    Somewhere in there you removed power to the rig without turning it off and then turned on the update switch and applied power to the radio and the radio turned on in update mode. There is probably where some of the problems began. Good luck.

    Oh, and when updating the software the first thing that happens is the EEPROM is erased. Then rewritten with the new. It's not a patch job.

    Fix the Serial port first.
     
  5. KC8QVO

    KC8QVO Ham Member QRZ Page

    If you are referring to my description of the S meter tanking from full scale so S5 - normally I would agree with you, and I mostly do agree. However, I have a rig here that I fixed by changing the internal gain off of spec and bringing it back in to alignment. Since that doesn't require a part replacement it is worth a shot to at least try it. The best that could happen is it improves the condition. The worst - nothing changes. If nothing changes I can move on from there. But that's where things are way down hill at the moment - I can't get there because of the communication issues.

    I said that in the first post, and reinforced it in the 4th:
    How is the rig functioning right now? It is stuck on 1.12 as per the Checksum return and it is seemingly working (I can operate the rig). However, the voice synthesizer is not working. Is there something in the EEPROM programming that affects the voice synthesizer? If so, and if that was erased/damaged, then how come I can still operate the radio aside from the voice synthesizer? Granted, I don't know what the limitations are in how the rig is "working", but it takes memory channels and works on repeaters fine.

    The above also doesn't make much sense - when I first flashed it to 1.12 the PTT didn't work very well. How that is working now, on the same firmware, while the voice synthesizer does not is a mystery.
     
  6. VE1IC

    VE1IC Ham Member QRZ Page

    does the voice synthesizer need to be enabled in the menu? Change the language maybe? unplug it and plug it back in? Does the rs232 work now?
     
  7. KA9JLM

    KA9JLM Ham Member QRZ Page

    Normally memory is addressed in Blocks, If Block addressing is messed up, A device on the data bus can be calling the wrong address.

    Normally, A firmware update is not exactly the same size in memory, So a block address may change, Do to the memory size required for the firmware update.

    Going backwards with update versions may have caused problems.

    Good Luck.
     
    Last edited: Aug 16, 2020
  8. KC8QVO

    KC8QVO Ham Member QRZ Page

    I never got to the back-date. I captured the rig to do the back-date, but that is the step that things got buggered up with - when I plugged the rig back in with S1 in programming mode to do the back-date it powered up and things have been the way they've been since - screwed up. So, when I check the Checksum I get the code for 1.12 right now. I lost serial communication at the point I was going to push 1.08 again.
     
  9. KE5MC

    KE5MC Premium Subscriber QRZ Page

    My first rig was a TS2000, unknow firmware version, which I connected to a PC using a Edgeport USB to 4 serial ports. So my comments are from memory and experience with RS232 connection as the rig is long gone.
    Looking at the schematic you have 5 lines to deal with. Data in, Data out and signal ground are the easy ones. The other two are flow control and likely one is output and other is input without looking up the device data sheet. If you were using a 3 line connection without flow control you would likely have setup the TS2000 to ignore handshaking. Possibility in the firmware update that setup configuration was lost. I'm not really sure if the TS2000 has the ability to ignore handshake in any firmware version or it was a software addition. I'm sure I strapped the back of the connector at the radio to effectively ignore handshake. RTS, CTS, DTR and DSR are the typical ones to work with to strap "happy". Now if your serial cable is fully wired then I would suspect the PC end is not turning on a signal the radio needs to see.

    Lots of information to follow in the thread and I only added what I know that I did not read or recall reading. All the other comments are still relevant and the voice not working is troubling, but again could be a lost configuration in update. RS232 has layers of settings and if any setting is not in place correctly the port looks dead. Something like a RS232 inline breakout box with LEDs and jumps can easily diagnosis the connection. Not a common tool anymore, but a life saver for old school RS232.

    Good Luck!
     
  10. VE3CLG

    VE3CLG Ham Member QRZ Page

    Yes as you say your usb rs232 working fine with other things like psk31 and so on.
    I do not know if you have the driver for it, but even if you do not , just try this.
    Go to Device manager and uninstall the driver .
    Then turn OFF ur pc.
    Start ur pc with out the usb rs232 .
    Then install the driver for it if you have the correct driver.
    Then turn OFF again the pc.
    Now before you start your pc plug the usb rs232 .
    When you start the pc go back at the Device manager and look what what port it is.
    Now go at the ts-2000 menu and place the same port # and same baud .I thing it is at 9600
    then if the ts-2000 and the usb rs232 at the same info, then plug the radio and give it a try.
    Just try it and you never know maybe it is going to work.
    A and a good hard reset at the radio that maybe help.
    I have a usb rs232 and it works fine with my ts-870s for a RcForb Remote station but is not working for psk31.
    You have nothing to loose any way.
     

Share This Page