ad: KE5EXXad-1

TS-2000 firmware+com port communication issues

Discussion in 'Radio Circuits, Repair & Performance' started by KC8QVO, Aug 13, 2020.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: abrind-2
ad: L-MFJ
ad: Left-2
ad: Subscribe
  1. KC8QVO

    KC8QVO Ham Member QRZ Page

    All,

    I am working on a TS-2000 here (SN starts with 303). The primary issue at the moment is I am not getting the rig to communicate with a computer through a USB to serial adapter now. It did and it took the software update from 1.08 to 1.12 fine. That is where things went south.

    For reference also - the software updates in the revision history or downloads page on Kenwood's site said the newer software includes all previous updates. So I assumed the versions did not need to be stepped.

    After the 1.12 software update I did a hard reset then loaded the memory channel/menu image back in. The rig would not work properly. It powered up fine but would not take the PTT from an external mic. I tried the Send button and it locked in to transmit and would not unkey. So I turned the rig off.

    After that I tried to back-date the firmware to 1.08. I noticed in the dialogue boxes in the firmware writing software after the first step of connecting to the rig with the power on and the switch inside the case off it does not state to turn off the rig, just to remove power. So I pulled the cable while the rig was ON (which turned it off), then moved the internal switch to the programming/on position, then plugged the power cable back in. The rig powered up. I think this is part of the problem with the rig now - it powered up with the programming switch in the ON position and I don't think it is supposed to.

    Anywho, I tried to continue with the firmware flash back to 1.08 but it would not take - the com port communication would not reconnect.

    I put the switch back to the normal/off position (with the rig off/unplugged) and performed a couple hard resets. I also tried bumping the baud rate to 19,200 from the standard 9600. No luck.

    At this point I can not re-establish communication through the serial port. That, I believe, is the primary issue.

    The secondary issue that I was in the process of working through was why the rig was acting strange on 1.12. What I would like to do is get the rig back to 1.08 so I am back where I started - but I can't get there because I can't communicate with the rig via the com port.... So the com port issue trumps all else at the moment.

    For the record, I backed up everything from the memory control program as well as the service software. I have tried, likewise, to reflash the memory channels/menu items back in to the rig from both software programs as well - same issue - no com port communication with the radio.

    This rig does have the voice announcer option in it. When I got to 1.12 it was working. Then in the issues I've had since the voice announcing has not worked (I have not tried to find any settings for it, on/off, volume, etc yet, though).

    Ideas?
     
    Last edited: Aug 13, 2020
  2. VE1IC

    VE1IC Ham Member QRZ Page

    tried a different computer with a real serial port?
     
  3. VE3CLG

    VE3CLG Ham Member QRZ Page

    If your computer see the usb serial port , see at what port # it is baud rate and place the same info at ur ts-2000
    Then restart ur computer and then connect radio and try it
    hope that helps
     
  4. KC8QVO

    KC8QVO Ham Member QRZ Page

    The serial port and baud rate of the converter aren't the issue. I can communicate with the serial to usb converter fine and it was communicating with the radio fine until the mentioned attempt at back-dating the firmware. The computer started off the first part of the back-date by capturing the TS-2000 - as it should - when on. I lost communication when the rig powered up after plugging back in once the firmware writing switch was turned on inside the rig.

    I CAN'T communicate with the TS-2000.

    I've tried 2 different computers - both a win-10 and win-xp. Both see the USB to serial converter fine. They DON'T see the TS-2000, nor does the TS-2000 ever show "PC" in the top right corner, not even a flicker.

    Tried rebooting computers.

    So the question is this:
    The serial connection in the rig appears to be bricked. How do I un-brick the serial connection inside the rig?

    Then, the 2nd question is the voice announcer doesn't work - it quit at the same time the serial connection did also.

    For what it is worth, my USB to serial converter runs my RigBlaster just fine. There isn't an issue with the converter otherwise the RigBlaster wouldn't work, either.
     
  5. KA5IPF

    KA5IPF Ham Member QRZ Page

    Drag out your 'scope and see if the RS232 I/O IC failed, most likely scenario with all the plugging and unplugging.
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    Clif is the man and could be right, He normally is.

    But stepping updates one step at a time can be very important. That is one reason all previous updates are still available.

    Each version knows how to update from the previous version before it.

    Good Luck. Many updates are made to kill the device so you will buy a new one. o_O
     
  7. KC8QVO

    KC8QVO Ham Member QRZ Page

    See red box in the picture. That is the download page for the latest software. You can get there from the link here:
    https://www.kenwood.com/i/products/info/amateur/pop_ts2000.html

    update includes all previous updates.jpg
     
  8. KC8QVO

    KC8QVO Ham Member QRZ Page

    I believe that would be the ADM202EARU/ADM3202ARU. However, I am not sure how that correlates to the voice synthesizer not working either. I suppose I will have to check both, starting with voltages.


    serial IC.jpg
     
  9. KA5IPF

    KA5IPF Ham Member QRZ Page

    I have one question. You said you were working on a TS2000 and decided to update it. Was it working correctly before you updated it? After updating did you try it before reloading the Mem/Menu stuff?
     
  10. VE1IC

    VE1IC Ham Member QRZ Page

    As I see it, there is no initial handshake happening to tell the computer and software "hi, I am here! Load me up!" You can verify this a few ways. It is possible for the ADM to die. I had the usb hub contoller inside my TS-990 die a few years back.
     

Share This Page