Trying to get FLdigi to work with IC 7100

Discussion in 'Working Different Modes' started by WM4MM, Oct 24, 2016.

ad: L-HROutlet
ad: l-rl
ad: HRDLLC-2
ad: Left-3
ad: Left-2
ad: MessiPaoloni-1
ad: L-Geochron
ad: L-MFJ
ad: abrind-2
  1. WA9FBC

    WA9FBC Ham Member QRZ Page

    OK Blake-
    I Set the above items. Rig not tracking freq or anything with flrig. Tried both my com 3 & 4.
    Sometimes crashes with "flrig not responding" We are getting closer to working!

    Dennis
     
  2. K5URU

    K5URU XML Subscriber QRZ Page

    Alright, let's dig a little deeper. I probably left something out or changed something from default settings that I forgot about.

    Let's go through the settings in the IC-7100 first.
    Set --> Connectors --> CI-V
    CI-V Baud Rate = 19200
    CI-V Address = 88h
    CI-V Transceive = OFF
    CI-V Output = OFF

    Here's what my flrig settings screen looks like. Let's match yours to this (other than your COM port) and see if that gets us anywhere.

    flrig-IC-7100.PNG

    Let me know what happens...

    K5URU
     
  3. WA9FBC

    WA9FBC Ham Member QRZ Page

    OK Blake!! Had several changes....not sure which one did it, but I had C-iv transavt ON & my
    baud in flrig was at 9600. Also unchecked 1 bit & echo & checked 2 stop bits. Had to check enable flrig
    xcvr control too to get it to key from fldigi.
    Thanks so much! I will try making a QSO tomorrow.

    73
    Dennis


    .
     
  4. AA4MR

    AA4MR Ham Member QRZ Page

    Blake.

    This Mary, AA4MR, in Florida. You assisted me with settings for my IC7100 for FLDigi. I was hoping that you might be able to advise on what setting changes are necessary to switch back to SSB voice operation. So, many changes were required for Data transmission that I am not sure how to simply switch back and forth between the two.

    Thank you,
    Mary, AA4MR
     
  5. KA9JLM

    KA9JLM Ham Member QRZ Page

    The setting should be under the menu Op Mode.

    Have Fun.
     
  6. K5URU

    K5URU XML Subscriber QRZ Page

    Hi Mary,

    To get back to SSB operation, there are just a couple of things to change. First, hit the USB-D button, then hit DATA to turn off Data mode. Then, hit the same button again (which now says USB), and tap SSB to change it back to LSB (depending on the band, of course).

    The final thing that Flrig does that had me perplexed for a while is that it turns your mic gain down to 0 and leaves it there. So, just hit the Mic/RF Pwr button and get that mic gain back up to around 50%.

    On another note, there is an easier way to switch back and forth without having to go through those steps each time. I believe Icom calls them registers. Let's say you're on 40m and want to switch from Fldigi to SSB voice. After you close down Fldigi and Flrig, tap the "7" in the MHz part of the frequency display (as you normally would to change bands), then press and hold "7" on that menu that pops up, the IC-7100 will go to the next register for 40m. Set that one up for SSB as described above.

    Then, when you're ready to go back to Fldigi later on, hit the "7" in the MHz part of the frequency display again, then press and hold the "7" in the submenu. Repeat one more time, and you'll be back to the register that has your fldigi settings. My description makes it sound more complicated than it really is. I have my registers set up for Digital mode, CW, and SSB voice on each band.

    Incidentally, Flrig has an option to "return radio to previous settings" that would make all this unnecessary, but I've never been able to get it to work on my setup.

    Good luck!

    73
    Blake K5URU
     
  7. K5URU

    K5URU XML Subscriber QRZ Page

    A few more things to add when switching back to SSB Voice from Data:
    - Compression (Off for Data, On for voice)
    - AGC (Off for Data, On for voice)
    - Noise Blanker/Noise Reduction (Off for Data, On if needed for voice).
     
  8. AA4MR

    AA4MR Ham Member QRZ Page

    Thank you! I am now able to return to SSB operation. I appreciate your expertise and detailed response.
    You are the best!
    Mary, AA4MR
     
  9. WA9FBC

    WA9FBC Ham Member QRZ Page

    Hi Blake-
    So I have fldigi working--thanks to you. But now I would like to get audio out of the headphone jack
    on the PC. I found the mixer, & picked the other choices, but still no audio out of the jack.
    How do I do ot?

    Dennis
     
  10. K5URU

    K5URU XML Subscriber QRZ Page

    Hi Dennis,

    I'm glad to hear that you're having success with fldigi.

    Try this and let me know if it works. I use Windows 10 and this is how I set it up. Other versions of Windows (or different sound card drivers) may be slightly different, or might not even have this capability.

    Right click on the speaker in the Windows task bar, then select Recording Devices, then double-click your IC-7100 USB Audio CODEC device. Click the "Listen" tab, and check "Listen to this device." Right below that checkbox, make sure you have your normal computer sound card selected. Then hit OK, and you should start hearing the audio from the IC-7100 being passed through to your computer speakers/headphones.

    (Note that this doesn't adversely affect the operation of fldigi, WSJT-X, or any other USB audio-based digital radio program.)

    73 and Happy New Year!

    Blake K5URU
     

Share This Page