Trying to get FLdigi to work with IC 7100

Discussion in 'Working Different Modes' started by WM4MM, Oct 24, 2016.

ad: L-HROutlet
ad: l-rl
ad: MessiPaoloni-1
ad: Left-2
ad: abrind-2
ad: Left-3
ad: L-Geochron
ad: HRDLLC-2
ad: L-MFJ
  1. WM4MM

    WM4MM Ham Member QRZ Page

    I am trying to help my sister n law set up fldigi on her Icom 7100 and windows 10. The problem is with win 10 you cannot display what port you end up on . The IC 7100 has a built in sound card so that it can be handled with 1 usb cable. The instructions want you to be sure to look at what port you are using but as stated Windows 10 does not display port settings in the device manager. Some say that if you go ahead and power up the radio that the port will display. The radio instructions caution not to hook up the cable until you set up the port. Needless to say that caution makes us reluctant to do so fearing damage to the radio. Has anyone done this with the 7000 series Icom/Win 10?
     
  2. K7MEM

    K7MEM Ham Member QRZ Page

    It sounds like you are in a "Catch 22". But it's quite possibly of your own creation. Not on purpose, of course. This is what technology brings with it.

    You need to remember that you are now dealing with two PCs. One is your laptop that runs Windows 10 and the other is the IC 7100. So when they talk about not pluging in the USB cable until the driver is installed, you need to determine which PC they are talking about. Your Windows 10 PC or the IC-7100.

    The writer(s) of the manual for the IC 7100 do not know what you are connecting the USB port to. So their instructions are not talking about installing and setting up the driver in the Windows 10 PC. They are talking about setting up the driver in the IC 7100. On page 1-18 of the IC 7100 manual there are some links to the driver source and instructions on installing the driver. Once the driver is installed in the IC 7100, you should be able to plug in the USB cable and see the port on your Windows 10 PC.
     
  3. K5URU

    K5URU XML Subscriber QRZ Page

    Icom cautions you not to hook up the cable until you install the driver in Windows. You won't be able to see the ports until the driver is installed and the radio is connected and powered on. By the way, the reason for the caution is only to make sure the driver installation proceeds correctly. If you connect the radio and turn it on before installing the driver, Windows will automatically (and incorrectly) install what it believes to be the appropriate drivers. The whole process is just much easier if the Icom drivers are installed first, before connecting the radio. You won't damage the radio or the computer if you connect before installing the Icom driver, but it will take some moderate to advanced Windows troubleshooting to resolve the incorrectly installed drivers.

    Anyway, enough with that. Let's get your sister-in-law on the air.
    I'm running an IC-7100 with fldigi on Win10. Here's how I did it:

    1. Start with the radio turned off and disconnected.
    2. Install the IC-7100 driver from the Icom website.
    3. Launch Device Manager (just click the main Windows "Start" button and type Device Manager).
    4. Expand the Ports section of Device Manager and take note of which COM ports (if any) are already listed.
    5. Connect the radio's USB cable to the computer and power on the radio.
    6. Go back to the Device Manager window and take note of the TWO new COM ports that have appeared. They should both be named something like "Silicon Labs CP210x USB to UART Bridge (COM5)"
    7. One of these is the CAT control port for the Icom. The other is for another function.

    At this point, you'll have all the connections, ports, and audio interfaces installed and ready to go.

    Note that there will be TWO new COM ports. You won't hurt anything on the radio or computer by trying one, then trying the other if the first one doesn't work. Make sure to also set your Audio in fldigi to use the IC-7100's sound card, which will appear as "USB Audio Codec" for both Capture and Playback.

    There are several ways to set up CAT control (RigCAT, HamLib, etc), and some of the settings will need to match what the IC-7100 has set in its own menu system. If you need any help with that, just let me know and I'll be happy to walk you through it.

    Good luck!

    73
    Blake K5URU
     
    K3DBI, W4WTA and W1XWX like this.
  4. KE0CAA

    KE0CAA Ham Member QRZ Page

    Windows 10 still has device manager. Microsoft does a good job of hiding it from the average user. http://www.primemsp.com/content/msc_Shortcuts.aspx has a nice list of the various microsoft support tools. The one your looking for would be Device Manager, devmgmt.msc. The fastest way to get there is to hold windows key and hit the r key to open a run box. Then type in devmgmt.msc and hit OK. That should open device management to view the ports and device status.
     
    W1XWX and KA9JLM like this.
  5. AA4MR

    AA4MR Ham Member QRZ Page

     
  6. AA4MR

    AA4MR Ham Member QRZ Page

    Blake:

    Thank you for your response to this question. I am the 'sister-in-law' that Mike, WM4MM, was referring to. My name is Mary, AA4MR. I am stilling trying to get my IC-7100 set-up to run FLDigi. I finally have FLDigi and FLRig downloaded and installed with radio connection.

    I have read many online web pages and made multiple changes to both the radio and program settings. However, I cannot see the waterfall. Not sure what is wrong. Perhaps you have some advice on the settings?

    Mike will coming over tomorrow to assist me. Perhaps, with his help and your input we will be successful.

    73
    Mary, AA4MR
     
  7. K5URU

    K5URU XML Subscriber QRZ Page

    Hi Mary,

    Excellent. You're almost there!

    There are a few settings in the IC-7100 that we should look at. I don't remember what the factory settings were, but I do remember having to change a couple of these to get fldigi (and WSJT-X) working. After that, we'll double-check the Windows and fldigi settings. You've probably already made some of these changes, but I'll include as much as I can remember here for the sake of reference.


    IC-7100

    First, make sure you're in USB-D mode (Upper SideBand - Digital). Just set the radio to USB as you normally would, using the touch-screen button. Then hit that same mode button and touch Data. The mode should now display as USB-D. You'll want to return to this mode any time you run fldigi, WSJT-X, WSPR, or any other computer-controlled digital mode. Some programs will automatically switch your Icom into this mode; others will not.

    Once you're in USB-D mode, hit the Set button, and go into the Connectors menu. Adjust your settings as follows. (I'll skip the ones that don't affect USB cable operation).

    USB Audio SQL = OFF (OPEN)
    ACC/USB Output Select = AF
    ACC/USB AF Level = 100%
    DATA MOD Level = 100%
    USB MOD Level = 100%
    DATA MOD = USB

    That's it for the IC-7100. Back out of the menu to get back to the main screen on the radio.


    Windows:
    In Windows, right-click the speaker icon by the clock and go to the Playback Devices screen. Double-click on the USB Audio CODEC device.
    - Optional: Here, you can rename the device to IC-7100 if you want to.
    - Click the Levels tab. Right-click the text box to the right of the slider and select decibels. Adjust the slider so the text box shows 0.0 dB.
    - Click the Enhancements tab. Check the box next to "Disable all enhancements"
    - Click the Advanced tab. Set the Default Format to 16 bit, 48000 Hz (DVD Quality)
    - Click OK

    Back in the Sound window that has the Playback devices listed, click on the Recording tab. Once again, double-click on the USB Audio CODEC device.
    - Optional: Here, you can rename the device to IC-7100 if you want to.
    - Click the Levels tab. Right-click the text box to the right of the slider and select decibels. Adjust the slider so the text box shows as close to 0 dB as you can get it. In my case, it is set to +0.1 dB.
    - Click the Advanced tab. Set the Default Format to 1 channel, 16 bit, 48000 Hz (DVD Quality)
    - Click OK

    Click OK on the Sound window and you're all done with Windows setup.


    Moving on to fldigi:
    In the Configure menu, click Sound Card.
    - Check the box next to PortAudio.
    - Set both the Capture and Playback dropdown menus to USB Audio CODEC. If you renamed the devices in the optional steps above, you'll see "IC-7100 (USB Audio CODEC)" in these menus.
    - Click Save, then Close to get back to the main fldigi window.

    That should just about do it. Hopefully, you'll be seeing the waterfall and you'll be able to transmit data as well. Again, if you have any further questions (or you have anything to add), please let me know!

    Good luck!

    73
    Blake K5URU
     
    W1XWX likes this.
  8. WA9FBC

    WA9FBC Ham Member QRZ Page

     
  9. WA9FBC

    WA9FBC Ham Member QRZ Page

    Hi Blake-

    I am having trouble getting fldigi to xmit. I set all the setting u suggest, but not keying the 7100.
    I am running Win 8. Any ideas to get it going?
    Thanks
    Dennis
     
  10. K5URU

    K5URU XML Subscriber QRZ Page

    Hi Dennis,

    It sounds like you've got everything working except the rig control portion. There are several options for rig control through fldigi. I prefer using flrig, so I'll share with you how I have my station set up that way.

    Flrig is a separate application that works with fldigi and provides access to many of the controls you will use for digital modes, including RF gain, Power, VFO, and several others.

    Here's the download link:
    https://sourceforge.net/projects/fldigi/files/flrig/

    Picking up where I left off in my latest response, we just need to set up rig control.

    In Windows:
    Let's find out which COM port your IC-7100 is using. To do this:
    1. Launch Device Manager (just click the main Windows "Start" button and type Device Manager).
    2. Expand the Ports section of Device Manager and take note of the TWO separate COM ports that are named something like "Silicon Labs CP210x USB to UART Bridge (COM5)". These represent the two types of control ports available for the Icom. One is for traditional CAT control, and the other is for Icom's CI-V control. For flrig, we'll be using CI-V. You won't hurt anything on the radio or computer by trying one, then trying the other if the first one doesn't work.

    In fldigi:
    Go to Configure --> Rig Control. Make sure the following checkboxes are all UNCHECKED:
    - RigCAT tab: "Use RigCAT"
    - Hamlib tab: "Use Hamlib"
    - Hardware PTT tab: "PTT tone on right audio channel"
    - Hardware PTT tab: "Use separate serial port PTT"
    - XML-RPC: "Use "XML-RPC program"

    In the final tab, flrig, CHECK the box that says "Flrig PTT keys modem"

    Click Save, then Close in the settings window.

    Now, let's set up flrig.

    In flrig:
    - Click Config --> Setup --> Transceiver
    - In the Primary tab, set Rig to IC-7100
    - Ser. Port: (Set this to one of the COM ports you discovered earlier. Later on, if this setup doesn't work, you'll change this to the other COM port you discovered earlier.)
    - Click the Init button, wait a few seconds, then hit Close.

    At this point, your flrig window should show the Frequency and other settings that match what's on the IC-7100's display. Changing the frequency in flrig should change it on the IC-7100, and vice versa. If this is not the case, go back to the Serial Port setting in flrig and try the other serial port (then click Init and Close again).


    Wrapping up
    Now, you should be able to open fldigi and have full control of the rig, and also have the current frequency displaying in fldigi. Run a quick test transmission on low power, and you should have full PTT control.

    There are a lot of other settings you can use to tweak the performance and options for this setup, but hopefully, this intro will get you on the air.

    If you have any further questions or get stuck along the way, please do not hesitate to reply here or send me an email. I would be happy to help you get everything set up.

    73

    Blake
    K5URU
     
    K3DBI and WB6ODR like this.

Share This Page