ad: Correctmanual-1

TH-78A 'left side problem'

Discussion in 'Radio Circuits, Repair & Performance' started by N9ZDZ, Nov 18, 2016.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: l-assoc
ad: MessiPaoloni-1
ad: Subscribe
ad: L-MFJ
ad: Left-3
  1. N7EKU

    N7EKU Ham Member QRZ Page

    Hi,

    The value should have been written on the caps no? You need to measure the diameter and height too, so they will fit in OK.

    I ordered mine from Digikey. Light stuff like that they can ship in an envelope for a few bucks and it should arrive in a couple days. No minimum order either, and they have all the dimensions you need listed.

    73,


    Mark.
     
  2. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    well I ordered new ones but I found 2 others from another project so I should be able to fix it right
     
  3. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    seems to be working now except I am missing a line on the volume display so need to find out what happened there. plus I bought a charger for it and its not charging or the battery isn't any good
     
  4. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    well got the new caps in today finally and perfect size too. hope this fixes everything in the radio
     
  5. KD6RFJ

    KD6RFJ Ham Member QRZ Page

    Curious if you fixed this problem. I have the same issue. Wondering if anyone knows POC and cost to rrepair.
     
  6. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    Well I never done the one I had before because the person who owned it before bunt the board bad but I am in the middle of doing another one that a guy sent to me for me to do. will keep you updated
     
  7. HL5JRN

    HL5JRN QRZ Member

    Hi All,
    I had the same TH-78 left side problem and here is my investigation result.
    Actually I had two troubles on TH78, one was no or weak audio/no RF out and no encoder working.
    The other was the famous leftside full signal/open squelch.
    Both failures were due to the SMD chemicon leaks and that corrodes PCB traces.
    The corrosion cuts two different traces, one of traces was 5MS (4.8V) which causing no audio, no RF power and no encoder work
    so I did jumper between the 2 ribbon cable's 5MS terminals that cured no audio, no RF and no encoder work. The other cut took place between
    VR307 (1.5K) and R399 (560ohm) that caused the left side problem, so I did a 2nd jumper for that and the problem cured!
    Hope you could fix the same problem.
    Good luck,
     
    N9ZDZ likes this.
  8. N9ZDZ

    N9ZDZ Ham Member QRZ Page

    I got his radio fixed nice
     
  9. KG5UMH

    KG5UMH XML Subscriber QRZ Page

    Old thread with relatively current posts - Great as I have questions.
    Got one of these handhelds given to me. The problems seem to be?
    Radio works when plugged into charger, but not with new NiCad Battery -
    Left side Open Squelch - (I think). With out the antenna on the squelch can be adjusted on both sides. With the antenna on, the left side goes to open squelch.

    Nothing else that I have found - If I can solve the power problem, the left side problem does not look to bad -

    TIA
     
  10. KA9JLM

    KA9JLM Ham Member QRZ Page

    I would suspect external interference.

    Have you tried it at a different location ?
     

Share This Page