ad: FlagAnt-1

Strange FoxTelem issue.

Discussion in 'Satellite and Space Communications' started by K3RLD, Jan 13, 2018.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Left-2
ad: Subscribe
ad: L-MFJ
ad: l-assoc
  1. K3RLD

    K3RLD Ham Member QRZ Page

    Recorded about 10 minutes of audio with GQRX during this morning's image test (filter set to 20kHz), being controled with GPredict. Keps are a little off, so I manually correct, and it was never more than 1.5kHz off. Decoded with FoxTelem 1.4 (wave file option) and it got around 9 high speed frames. These were uploaded to the telemetry server automatically. Checked the camera tab and it didn't show anything to even indicate the frames were image related.

    So I then took the audio file to my other cheapo laptop - also running Ubuntu (as the one above), but which had FoxTelem 1.05 installed. Ran the same audio file through this version and zero decodes. No DUV frames. No high speed frames. Even tried the PSK decoder. NYET!

    Any suggestions?
  2. K3RLD

    K3RLD Ham Member QRZ Page

    Another observation: 1.04 decodes wav files at lightning speed. A 10 minute recording is decoded in about 10 seconds. 1.05 only seems to decode the same wav file in real-time. Can't find a setting to adjust that (if it exists).
  3. KG4AKV

    KG4AKV Ham Member QRZ Page

    Not sure about the main problem but I think the quoted issue is "fixed" by clicking "Squelch when no telemetry" under Audio Options on the right side.
  4. K4KDR

    K4KDR Ham Member QRZ Page

    I'm sure you saw it visually in GQRX, but what was your approx. capture bandwidth in the RF window? Of course you always want to adjust the RF bandwidth to just exceed whatever waveform you're capturing.

    But that is probably not what happened to you.

    GQRX has a setting that is somewhat hidden that MUST be adjusted for the higher data rates.

    On the "Receiver Options" tab, when Mode is set to "Narrow FM", click the "..." to the right of the mode selection.

    For 9k6 data, you'll need to be set that to at least 17 KHz.

    Should you ever use GQRX for a 19k2 data stream, then the 25 KHz setting is appropriate.

    Of course the 25 KHz setting would work for 9k6 data as well, but I suppose you lose a bit of the SDR's sensitivity by listening to the additional noise outside of the data stream.

    I did not know about this setting for the longest time and naturally was never able to decode any FSK (FM) rate higher than 1200 (and had no idea why!).


    -Scott, K4KDR
  5. K3RLD

    K3RLD Ham Member QRZ Page

    Drew's recommendation was 18 kHz min, so I just used the default GQRX setting of the "wide" filter for "Narrow FM", which looked to be exactly 20 kHz. And it worked just fine for foxtelem 1.04, just doesn't work for 1.05.

    John - your suggestion worked! Still no decodes, but at least I don't have to wait 10 minutes to see that. :)
  6. K4KDR

    K4KDR Ham Member QRZ Page

    The reference to "Narrow FM" with the "wide" filter is the RF bandwidth. I was speaking of the audio output bandwidth. You'll need the adjustment that I mentioned to the audio stream (17 or 25 KHz instead of the default 5) to end up with an audio output that will result in a successful decode of 9600 data.

    Both settings are important, but they're completely different.
    K3RLD likes this.
  7. K3RLD

    K3RLD Ham Member QRZ Page

    Ah, got it. However still doesn't explain why the exact same recording decodes just fine with 1.04 and not 1.05.
  8. N0JY

    N0JY Premium Subscriber QRZ Page


    I don't know for sure, but there may be something with FoxTelem 1.05. You are running 1.05y?
    Last night I was running some old Fox-1D test recordings both AF and IQ, and FoxTelem 1.05y would not decode them unless I ran them through HDSDR or SDR# or turned on the MONITOR AUDIO when I ran them in FoxTelem. I was trying to get through the files quickly before we did the camera run, but wound up playing them "real time" although at the time that didn't really bother me because I wanted to hear the high speed data again to refresh myself on the sound pattern after 2 years, for listening to the live downlink. So I sort of forgot about the not-playing part when I finished and came to the office for the tests. Were your files IQ or AF? If IQ, when you played the high speed through FoxTelem, did you do it directly by selecting the file as the source in FoxTelem? If so, with MONITOR AUDIO on, did you hear any clicking in the audio?

    I'll let Chris know, but he is very close to a new release that we are testing internally so I imagine the fix is to just wait a week or so until he makes it a general release.

  9. K3RLD

    K3RLD Ham Member QRZ Page

    Jerry, I just got 8 frames with AO-85 that decoded fine with 1.04 - I'll try them on 1.05 right now. These were AF recorded wav files. I can supply them if needed.
  10. K3RLD

    K3RLD Ham Member QRZ Page

    Ok, update. Took the same wav file that decode 8 AO-85 frames (actually it was 5 experiment frames, and 3 telemetry frames), and ran it through 1.05y (verified that it is "y").

    Of the audio options, only "squelch when no telemetry" is selected. The first minute or so of the file is no signal, as I had to lower the squelch threshold in GQRX to get to actually record at full open squelch, and during that minute or so - FoxTelem 1.05y crawled at about a real-time pace. At about the time when the actual squelch opens, it starts to decode at the superfast rate, but seems to "stall" every few seconds, then picks up again. This may or may not be due to the fact that I didn't set the squelch on GQRX low enough, and at some point I adusted it to stop squelching. Regardless of that, no frames were decoded when the file was completed. No clicking or anything was heard.

    When I run the same exact wav file through 1.04, it decodes the entire file flawlessly in about 10 seconds with the 8 total frames reported. I will try the high speed data from yesterday now and report back what I find. I should point out that as I was typing all this, xorg process was at 100% cpu usage (FoxTelem 1.05y was open in the background, but not decoding anything). Not sure whats up with that, either.

    The runaway xorg process i think was a fluke, but doesn't really matter. Ran the high speed stuff I recorded yesterday through 1.05y, and zilch. Even checked all the other audio options, no sounds heard or anything, no decodes.
    Last edited: Jan 14, 2018

Share This Page

ad: wmr-1