Soundmodem can't transmit properly: "sm[2721]: snd_pcm_start in iotxstart: Broken pipe"

Discussion in 'Computers, Hardware, and Operating Systems' started by VA1QLE, Mar 14, 2017.

ad: L-HROutlet
ad: l-rl
ad: L-rfparts
ad: Subscribe
  1. VA1QLE

    VA1QLE Ham Member QRZ Page

    I have soundmodem working fine on a laptop. I'm now trying to get it working on my desktop. I've tried 2 separate desktops and 3 sound cards, all give the same error. I've tried both Linux Mint 18.1 and Debian 8.7. Both computers are pretty old, one's from 2003 and the other is probably 5 or 6 years newer.

    sm[2721]: snd_pcm_start in iotxstart: Broken pipe

    As it implies, tx doesn't work, but rx is fine. I'm not sure how to fix it - Everything I've looked up implies it can be ignored, but in my case it clearly can't.

    Audibly, the output 'sounds' correct. After some research, the error comes from writing the sound async, so I have a feeling that output sound is out of order, which it why it sounds correct to my ears but not to the receiving computer.
     
  2. N0NB

    N0NB Subscriber QRZ Page

    Did the suggestions offered in reply to your Reddit post help? I see there is an old Debian bug report that came up in my search.
     
  3. VA1QLE

    VA1QLE Ham Member QRZ Page

    Ended up using Direwolf instead, it doesn't have a problem.
     
    N0NB likes this.

Share This Page