Some FT8 Intervals Don't Decode

Discussion in 'Working Different Modes' started by KG6MZS, Apr 30, 2020.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Left-2
ad: Left-3
ad: L-MFJ
ad: Subscribe
  1. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    That's one difference in our symptoms - the waterfall looks noticeably different in the non-decoding cycles on my machine - fuzzy. They do not sound any different when I listen. Here is an example:
  2. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    Thanks for the suggestion, but I have a Elecraft tech working with me on the problem. Great company - support on a Saturday! Just like you guys K7GQ - thanks.

    73 de Eric, KG6MZS
  3. W4KJG

    W4KJG Subscriber QRZ Page

    I'm not using a Virtual Audio Cable. If I'm using one of my SDRs, I'm hard patched from the audio card speaker output to either theaudio card line input or the microphone input with a real genuine wire cable. When I'm using one of my old analog radios I'm patching the radio audio out directly to the line in via an isolated transformer. Going the other way, from the computer to an analog transmitter I'm also using an isolated transformer between the radio and computer.

    I realized tonight that if I make changes in WSJT-X, such as from FT-8, to WSPR and back again, it takes several 15 second cycles for the WSJT-X 15-second interval lines to be properly spaced. That is, on my waterfall, there will be several 15-second intervals that are small, ranging from about 1/16 inch to 1/4 inch on my display. They are ragged as MZS reports.

    Once it starts to decode, the waterfall spacing on my screen is probably about 1/2 inch between 15-second periods. I have my waterfall speed set to "N AVG 1".

    However, even though it looks normal, it still doesn't necessarily decode on every cycle. Sometimes it does, other times it may miss just one 15-second cycle, or it may miss up to several minutes of decoding.

    At one point I thought it might be due to a slow AGC setting, but they are all disabled at this point. The S-meter or S/N meter does not show a change when decoding/not-decoding.

    My receiver has been running mostly continuously for the last couple of days on 30 meters, with some periods on 17, 15, 20, 40 and 160 meters. The results can be seen on PSKreporter, although it is difficult to see gaps when it doesn't decode. I'm still seeing 85-90 different countries over every day. (You should be able to see what I'm receiving by just setting PSKreporter to my callsign - W4KJG, for all bands, and for all modes.

    Thanks to everyone for looking at this issue.


    When I make changes to WSJT-X, or to my SDR receiver program, the
    waterfall speed N AVG 1
  4. KP4SX

    KP4SX Premium Subscriber QRZ Page

    But not today :)
  5. W4KJG

    W4KJG Subscriber QRZ Page

    You're right. After you posted that, I looked. Only 78 countries. Must have something to do with the Earth Shaker gods.:confused:
  6. KE5MC

    KE5MC Premium Subscriber QRZ Page

    I think your comment about waterfall line spacing is a telling symptom. Spacing for me is different when changing WSJT modes with different intervals or aborting a transmission that has not started as I wanted. It always readjusts for the next cycle with respect to spacing on the next cycle. If the waterfall space interval is not uniform I'm thinking the decoding process is at risk for intermittent failure. My thinking is some other process is "cycle stealing" or priority preempting WSJT. I'm just throwing out an idea based on your comment.
    Good Luck,
  7. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    Hello All,

    I thought I’d report back on the problem.

    Nothing I’ve tried has eliminated the problem, but it seems that the 3-5 intervals that do not decode occur pretty regularly. They are almost always in a row and then I get 7-12 good cycles.

    So for now I am only calling CQ or answering a CQ on the first or second good cycle and I can usually complete the QSO. Not optimal, especially when I get tail-ended with a juicy second call, but OK for now.

    I have been trying to get another computer in the shack to eliminate anything else in the signal chain, but it has been pretty hard given the lockdown and that I am considered a double high risk for the novel corona virus.

    I’m trying to get this MacBook Pro to run WSJT-X but so far the program will not talk to my K3. Strangely, the MacBook Pro does talk to the K3 via the K3 utility, it's just WSJT-X that wont play.

    I have another PC laptop in the works.

    So that’s the news from here. Thanks again to all that helped!

    73 de Eric, KG6MZS
    Last edited: May 5, 2020
  8. K7GQ

    K7GQ Subscriber QRZ Page

    How about posting a screenshot of your "Radio" settings from WSJT-X? Which Interface are you using on the K3 - RS-232 or USB?
  9. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    Here is what the settings look like on the Macbook Pro. As I said, Elecraft's K3 utility connects with these settings, WSJT-X does not
  10. K7GQ

    K7GQ Subscriber QRZ Page

    A few minor things I'd change though I doubt any of these have anything to do with the real issue. I'd set Handshake to NONE, make the PTT CAT port the same as the radio's port, and increase the polling rate to a few seconds. Alternatively, you could set PTT to VOX as I have done with my K3.

    One oddity I discovered on my 2013 MBP that has two USB ports - one on each side of the case - was that only one worked with the radio. It made no sense to me as that non-working USB port worked with any and every thing else.

    BTW - does your K3 have the USB or the RS-232C port?

Share This Page