Some FT8 Intervals Don't Decode

Discussion in 'Working Different Modes' started by KG6MZS, Apr 30, 2020.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Left-3
ad: Subscribe
ad: Left-2
ad: L-MFJ
  1. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    Interesting. I assume you are on the OSx side. I'm skeptical about how responsive the sampling is on the CPU usage on the PC side. I'm not sure I'm seeing the actual spikes on decode. They might be briefly higher than the 60% reported. The program runs at 8-10% the overwhelming majority of the time. It's only very briefly on decoding a dozen or more signals that it briefly goes up to 50-60%

    I also wonder why it will decode just fine exhibiting the exact same numbers repeatedly and then gack three or four times in a row. I can't find any correlation between the bad intevals and the good. I've listened to the audio closely and there is no discernible difference in the audio while at the same time the waterfall looks markedly different:

    https://hankstamper.tumblr.com/image/616741526129819648

    This leads me to believe it is some kind of software problem or incompatibility.

    I trying ti arrange to get a different PC in here to test that theory.

    Thanks again for your time and help. I really appreciate it!

    73 de Eric, KG6MZS
     
  2. K7GQ

    K7GQ Subscriber QRZ Page

    Yes, I confess that I'm on the Mac side of this. But why not install the Mac version and see if the problem goes away? Looking at 20m WSJT-X just now, it's decoding some 30 signals at under 8% CUPU utilization.
     
  3. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    That's a good idea! The radio computer is a vintage 2009 Intel 3.06GHz Core 2 Duo (Which might be the problem right there) and it will not upgrade to Mac OS X 10.

    But, I have a pretty new MacBook Pro running Catalina that I can pull out of my studio and try.

    Update: I got to the install Read Me instruction that says to launch WSJT-X and I get an error message that says: "“wsjtx” cannot be opened because the developer cannot be verified."

    I've emailed G4KLA, as instructed, to ask for help.

    I'm feeling a little snake-bit at this point. :)

    Thanks for the suggestion, I'll keep you posted...
     
  4. KP4SX

    KP4SX Premium Subscriber QRZ Page

    One thing I haven't seen mentioned so I'll throw it out there. Noise. If there is a noise blanker/limiter engaged and a bunch of noise starts up you might not hear it but it indeed fuzzes up signals on a waterfall like that.
    Make sure that any NL /NB is turned off.
     
  5. K7GQ

    K7GQ Subscriber QRZ Page

    There's several ways around this: open System Preferences and click on Security & Privacy. Now start WSJT-X again, switch back to the Security preferences, and respond to the message about WSJT-X. Another way is to hold down either the "control" or "option" (I don't recall which) and click on WSJT-X - selecting the "OPEN" option. Supplying administrator credentials permit the program to run and you won't be bothered again.

    There's a readme.txt in the install that you must follow very carefully before WSJT-X will run normally. BTW, I believe we have the same model 2009 iMacs.
     
  6. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    I figured that out just after I posted that, but thanks for letting me know K7GQ. Read the Read Me very closely and got WSJT-X installed.

    Now I can't seem to get the MacBook Pro's USB C port to speak to the RS232 port on the K3.

    The gods do not seem to want me in this particular waterfall :)

    73 de Eric, KG6MZS
     
  7. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    I have a pretty good understanding of sound card digital modes via Digital Master 780, so I got that covered KP4SX, but thanks for the suggestion.

    It's the intermittent nature of the visible fuzziness that is so confounding. And there is no audible difference between the clean and fuzzy intervals that I can hear.

    73 de Eric, KG6MZS
     
  8. K7GQ

    K7GQ Subscriber QRZ Page

    You might want to re-post this part to the Mac sub-forum under Computers, Hardware, and Operating Systems
     
  9. W4KJG

    W4KJG Subscriber QRZ Page


    I'm having the exact same problem. Sometimes it will decode every single time. Then it will go for two or three cycles, to two or three minutes without decoding anything. It is even worse on WSPR. Sometimes it will not decode WSPR at all. The waterfall looks perfect in all cases when it doesn't decode.

    I'm primarily using Time-Synch, which is set for 1 minute updates. I also have a bookmark for TIME.IS. It typically reports that +/- 0.02 seconds with a possible accuracy of of somewhere around +/- 0.05 to 0.08 seconds.


    I have tried all of the DECODE settings (Fast, Normal, Deep and with and without AP).

    I have not experimented Random Erase patterns nor the Aggressive decoding level, but I do have Two-pass decoding ON.

    I have printed out the Version 2.1.0 Users Guide (There isn't a 2.1.1 guide version.) I have gone through it line by line for most of the settings.

    I won't get a chance to play with it today. Maybe tonight or tomorrow. It is just very frustrating, as this only started happening the the last week or so. It is certainly working when it works. Typically PSKreporter shows that I've decoded signals from 85 to 90 countries over 24 hours on bands from 160 meters to 17 meters.

    I don't have any clue why WSPR has mostly quit. I've got a neighbor about two miles away running +20 dBm and he is quite strong. He is running at about a 40-50% schedule. I maybe decode one in 3 to 10, or none at all of his transmissions. There are other signals that even stronger than his. I know that I'm within 30 Hz of being on frequency, and nearly all of the signals I'm seeing on the waterfall are within the window around 1500 Hz WSPR operating frequency (except for those people who are actually outside of that window).

    Any further assistance would be greatly appreciated. I just find it really strange that I believe it was working extremely well until a few weeks ago and then this started happening. I've downloaded and re-installed WSJT-X a couple of times. It happens whether I'm using my SDR-Radio V3, SDR#, or stations on WEBSDR. It also happens if I'm using audio from one of my analog radios.
     
  10. KE5MC

    KE5MC Premium Subscriber QRZ Page

    I have just re-read the thread and one item that came to mind is Virtual Audio Cable. I don't know what VAC plays in anyone's setup so it might have no relevance to the issue. Awhile back using a SDR radio and DSDPlus for the first time in several months, the decode from DSDPlus were not happening. DSDPlus is similar to WSJT-X just looking at a different set of digital protocol's if one is not familiar. It turns out my problem was the sample rate in VAC was set to low. The VAC is a purchased higher end version. I always used the default which always worked, but for unknown reasons it was lower than it had been previously and I had to increase the sample rate. After making that change, decodes were fine.
     

Share This Page