Some FT8 Intervals Don't Decode

Discussion in 'Working Different Modes' started by KG6MZS, Apr 30, 2020.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: L-MFJ
ad: Subscribe
ad: Left-2
ad: QSOToday-1
ad: abrind-2
  1. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    Hello All,

    I've been doing digital modes for a long time via DM-780 and finally decided to try FT8.

    I've got everything working and have made a few QSOs but I am experiencing a vexing problem.

    If I reboot my computer, restart the K3 and launch WSJT-X 2.1.2, every single interval decodes just fine.

    Once I transmit, 3 or 4 intervals look fuzzy and do not decode at all.

    AHA! I thought: RFI. Wrong. When I put the K3 in Test Mode (no power out on TX), the same thing happens. Also I don't have any issues with DM-780, or when I run QRP or in different bands, so no joy there.

    Any ideas?

    Setup:
    Elecraft K3
    WSJT-X 2.2.2
    iMac running Windows 8.1 native on Boot Camp
    Soundcard: Focusrite Scarlett 2i2

    Thanks in advance,
    73 de Eric, KG6MZS
     

    Attached Files:

  2. KE5MC

    KE5MC Premium Subscriber QRZ Page

    DM780 modes while I have not looked at the resent update has not included, but talk was it might, WSJT modes. WSJT requires your computer clock to be accurate to 3 seconds or less. I use a Mac for everything just about, but radio and on the PC I replace the MS time support with a 3rd party NTP Time Sever. Sounds like you Mac is second accurate for awhile then drifts off. Look at the DT time in your decodes to verify. If it starts at +/- .1 and increases and decodes start to fail then you have a time problem.
    Good Luck
     
  3. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    Hi Mike, Thanks for the reply. When I boot up the Mac in Windows 8.1 I am using Dimension 4 every 10 minutes to keep the time accurate, but I will check the DT time for the +/- - thanks for the suggestion.

    73 de Eric, KG6MZS
     
  4. KE5MC

    KE5MC Premium Subscriber QRZ Page

    Now that the times out of the way. :) The non-decoding traces do seem fuzzy. I can't tell if that is caused by a decrease in the contrast which might point to a decease in signal amplitude. Only other thing I can think of is the sound card. In DM780 I have seen a calibrate check which I have not checked on my system for a long time. I'm wondering if that would help diagnose the issue.
    Mike
     
  5. W4HWD

    W4HWD Platinum Subscriber Platinum Subscriber QRZ Page

    There are times when WSJT won’t decode for me too. I simply exit the program and start it over which usually fixes it. In rare cases if the computer has been sitting turned on but idle for a few hours I have to restart the computer. My time is exact so that’s not the problem - I check it every time before I get on. Computer is Windows laptop, I just deal with it. My rig is also a K3s - using the built-in soundcard.
     
  6. K7GQ

    K7GQ Subscriber QRZ Page

    May I suggest that you install and run the native Mac WSJT-X version and see if that cures your problem. It's likely that the Boot Camp environment (and Windows) has just enough overhead to keep WSJT-X from having enough cpu cycles to do its' work.
     
  7. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    Thanks for the input. For me the problem does get better on restart, but the first TX seems to knock it out of whack and I don't want to litter the waterfall with broken QSOs.
     
  8. KG6MZS

    KG6MZS Premium Subscriber QRZ Page

    I've had that thought, but Boot Camp isn't an emulator - it runs Windows native off a dedicated partition - it shouldn't have any overhead. I certainly haven't seen any in the Task Manager. That's what's weird - the maximum CPU usage on a big decode is about 60%. I would think that would give the system enough headroom, especially after assigning WSJT-X and JT8 high priority .

    But your advice is well taken W4HWD, I am going to borrow a laptop from the local EOC and see if that fixes it. Thanks for the input
    73 de Eric, KG6MZS
     
  9. AE1N

    AE1N Ham Member QRZ Page

    Most decoding problems are linked to lack of precise computer time Synchronizatuon. You might try: https://neutron.en.uptodown.com/windows
    Also try the following FT8 settings:DECODE: Deep and Enable AP both checked.
    Under: SETTINGS: GENERAL do NOT click single decode
    Under: SETTINGS: GENERAL: Random erase patterns = 12
    Aggressive decoding level = 10 and click Two-pass decoding to ON.
    IF you get false decodes reduce Aggressive decoding lever one level at a time.
    Let us know how you fare!
    ---Layne AE1N
     
  10. K7GQ

    K7GQ Subscriber QRZ Page

    What's weird to me is that CPU utilization of yours. I've been using an old 2009 iMac with peaks at 8% CPU utilization with WSJT-X.
     

Share This Page