ad: elecraft

Serial Port - Access Denied

Discussion in 'General Technical Questions and Answers' started by W4DHX, Apr 6, 2009.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: K5AB-Elect-1
ad: Left-2
ad: MessiPaoloni-1
ad: Subscribe
  1. W4DHX

    W4DHX Premium Subscriber QRZ Page

    Thanks guys for your replies. I checked everything I could think of down to the port settings, IRQ's, baud rate settings, admin rights, etc(no conflicts). I dumped any PDA, Cell phone, FAX or other programs that I thought might hold the COM ports open but still nothing. I even bought a serial to USB cable and created other COM ports....access still denied...Tried connecting up with security software turned off and uninstalled - still no go. Finally I tried hooking up the Icom interface to an old laptop I had running the same XP OS....worked on the first try. Looks like I'm going to just re-format the HD on the desk top, re-install XP and start from scratch. Thank you all again for your time!
     
  2. KC2UYZ

    KC2UYZ Ham Member QRZ Page

    One more thing you might try (maybe it was already mentioned) is to check that the BIOS has the com ports open and addressed properly. That will specifically cause the access denied error message.
     
  3. KC2UGV

    KC2UGV Ham Member QRZ Page

    Is your account you're using to do this an Admin account? It could be possible you're logging in as a Guest, or a normal user.

    You're account needs to be at least a "Power User" account.
     
  4. WA9SVD

    WA9SVD Ham Member QRZ Page

    I've seen that; you must make sure that the standard COM: ports ARE enabled in the BIOS; I've also seen such a problem if a USB port device has somehow (either deliberately or thanks to Mr. Gates) been assigned to the same COM: port.

    What USB devices do you have connected to the computer? You MAY have to disable "Punt and Pray" to assign the ports to legacy parameters.
    (Isn't Windoze in all it's flavours just GRAND?)
     
  5. AB9LZ

    AB9LZ Ham Member QRZ Page

    Odd, when I open a com1 with an app I just wrote in C# (on a winders box of course) at 9600, n,8,1, it does it just fine, if I close that port and open it with hyperterminal at 19200, it does that just fine as well... my machine must be broken. ; ) In reality, like unix, windows treats a port like a file handle, many can read, but only one holds a lock for a write.

    I.e. if I open both, one returns an access denied, depending on who won the race to grab the port and write to it. Do you have AOL or some other malware autodialer installed on that machine?

    73 m/4
     
    Last edited: Apr 7, 2009
  6. W4DHX

    W4DHX Premium Subscriber QRZ Page

    Thanks for the support guys. I ended up formatting the HD and re-installing XP. When the system came back up the problem was solved. Since the BIOS looked good before I reloaded XP, I'm thinking it may have been some program I used (cell phone or PDA) that took control of the COM ports...and didn't fully uninstall when I took it out or some malware that went undetected. In any case thanks again for the assist.
     
    Last edited: Apr 8, 2009
  7. K7JBQ

    K7JBQ Moderator Volunteer Moderator QRZ Page

    While I hate to dredge up an old thread, this one speaks directly to the problem I'm having...with at twist.

    When I start HRD v.4, it recognizes my FT-890 and all is well.

    When I try v.5, I get the same error connect messages, and nothing I can do will make it work with the rig.

    LOGic8 and MixW also work perfectly.

    I thought I had a glitch witht he v.5 install, so I re-did it. Same deal.

    I've looked through the threads on the HRD boards, and haven't found a report of the same problem.

    Any ideas welcome.

    73,
    Bill
     
  8. WA4OTD

    WA4OTD Ham Member QRZ Page

    Try something else on that port. At least then you will know the port is ok.
     
  9. K7JBQ

    K7JBQ Moderator Volunteer Moderator QRZ Page

    OTD:

    Thanks. The port works fine with HRD v4.0 and with LOGic8. HRD v.5 just won't recognize the rig.

    73,
    Bill
     
Thread Status:
Not open for further replies.

Share This Page