SDRplay RSP comparison chart and update on availability

Discussion in 'Software Defined Radio (SDR)' started by G4ABQ, Dec 7, 2019.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: Left-3
ad: abrind-2
ad: Left-2
  1. G4ABQ

    G4ABQ Ham Member QRZ Page

    K2NCC likes this.
  2. K6CLS

    K6CLS Ham Member QRZ Page

    When are you going to fix the Linux driver installation script?
     
    KK4NSF likes this.
  3. G4ABQ

    G4ABQ Ham Member QRZ Page

    We've recently made some changes to the way the installer works for API V3.06. It's on the downloads page: www.sdrplay.com/downloads

    Not sure what "fixes" you are referring to. If you are still seeing problems then please raise a ticket on www.sdrplay.com/support
     
  4. K6CLS

    K6CLS Ham Member QRZ Page

    thanks. I'm trying to build the RSP API on Ubuntu 19.10 so I can use it with GNU Radio. Following the instructions here https://www.sdrplay.com/docs/gr-sdrplay-workflow.pdf

    With 3.01 I was getting "can't find the api library" error after cmake installed it to /usr/local/lib/libsdrplay_api.so

    I posted a question to your website two months ago, ran through the greatly annoying gauntlet of serial numbers, captcha etc., never heard anything from you.

    I'll try again with 3.06
     
    KK4NSF likes this.
  5. KF5LJW

    KF5LJW Ham Member QRZ Page

    I should probable start a thread for this, but I see company reps on this thread and should know the answer to my question about RSP2pro.

    Is there a minimum/maximum offset frequency for the LO?

    For clarification when you start the app, users are instructed to Click-Off center on the Waterfall display so the operating frequency and Local Oscillator are NOT EQUAL. Once done, then start app.
     
  6. K6CLS

    K6CLS Ham Member QRZ Page

    Hi, tried again with your 3.06, same error as with 3.01:

    cls@k6cls-p:~$ cd src/gr-sdrplay/
    cls@k6cls-p:~/src/gr-sdrplay$ cd build
    cls@k6cls-p:~/src/gr-sdrplay/build$ cmake ..

    -- Boost version: 1.67.0
    -- Found the following Boost libraries:
    -- filesystem
    -- system
    Checking for GNU Radio Module: RUNTIME
    * INCLUDES=/usr/include
    * LIBS=/usr/lib/x86_64-linux-gnu/libgnuradio-runtime.so;/usr/lib/x86_64-linux-gnu/libgnuradio-pmt.so;/usr/lib/x86_64-linux-gnu/liblog4cpp.so
    GNURADIO_RUNTIME_FOUND = TRUE
    -- Extracting version information from git describe...
    -- Boost version: 1.67.0
    -- Found the following Boost libraries:
    -- date_time
    -- program_options
    -- filesystem
    -- system
    -- regex
    -- thread
    -- chrono
    -- atomic
    -- libsdrplay not found.
    CMake Error at lib/CMakeLists.txt:43 (message):
    SDRPlay development files not found... Please visit sdrplay, download and
    install the API


    -- Configuring incomplete, errors occurred!
    See also "/home/cls/src/gr-sdrplay/build/CMakeFiles/CMakeOutput.log".
    See also "/home/cls/src/gr-sdrplay/build/CMakeFiles/CMakeError.log".

    ... And yet, there it is:


    cls@k6cls-p:~/src/gr-sdrplay/build$ locate libsdrplay
    /usr/local/lib/libsdrplay_api.so
    /usr/local/lib/libsdrplay_api.so.3
    /usr/local/lib/libsdrplay_api.so.3.01
    cls@k6cls-p:~/src/gr-sdrplay/build$ ll /usr/local/lib/libsdrplay_api.so*
    lrwxrwxrwx 1 root root 34 Dec 8 08:41 /usr/local/lib/libsdrplay_api.so -> /usr/local/lib/libsdrplay_api.so.3
    lrwxrwxrwx 1 root root 37 Dec 8 08:41 /usr/local/lib/libsdrplay_api.so.3 -> /usr/local/lib/libsdrplay_api.so.3.06
    -rw-r--r-- 1 root root 171920 Oct 16 23:07 /usr/local/lib/libsdrplay_api.so.3.01
    -rw-r--r-- 1 root root 198656 Dec 8 08:41 /usr/local/lib/libsdrplay_api.so.3.06
    cls@k6cls-p:~/src/gr-sdrplay/build$
     
    KK4NSF likes this.
  7. K6CLS

    K6CLS Ham Member QRZ Page

    Hi, any update? Please read my post above, there is something wrong with the cake script. Need your help with it. Thanks
     
  8. K6CLS

    K6CLS Ham Member QRZ Page

    I posted a question to your website two months ago, ran through the greatly annoying gauntlet of serial numbers, captcha etc., never heard anything from you.

    Thanks for your help with this.
     
    KK4NSF likes this.
  9. KK4NSF

    KK4NSF Ham Member QRZ Page

    I've got to agree with K6CLS that the Linux installation is still problematic at best.... bordering on unworkable. The problem appears to be that the API / Installer is incomplete, and relies upon files that are not included in most of the distributions I've tried.

    At the moment, I'd like to use your RSP2pro in my RA work.... but because it is such a pain to use with Linux, I've had to rely on a totally different system. This is a shame, since the radio would be perfect for the task IF it was compatible.
     
  10. G4ABQ

    G4ABQ Ham Member QRZ Page

    We made an update a Linux API update on 6th December. If you email me directly on jon.hudson@sdrplay.com I will help you best I can.
     

Share This Page