SDRPlay and Linux

Discussion in 'Software Defined Radio (SDR)' started by KC3SWL, Jul 23, 2019.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: L-MFJ
ad: FBNews-1
ad: Left-3
ad: Left-2
  1. K6CLS

    K6CLS Ham Member QRZ Page

    which linux distribution are you using?
     
  2. KT1F

    KT1F Ham Member QRZ Page

    My comment you quoted was a bit ambiguous, sorry. I'm actually running SDR# in VirtualBox, not SDRPlay.

    I had similar issues with the USB. It was usable but bad enough to be quite annoying with lots of clicks and interuptions when I tuned quickly. I spent more time than I care to admit fiddling with different settings and rebooting without much luck. Then I realized an obvious solution, at least for Airspy. I run SpyServer on the Linux host and talk to it from Windows in VirtualBox through the network, just as if it was a remote SDR. That works nicely.
     
    Last edited: Jan 30, 2020
  3. W2JKT

    W2JKT Ham Member QRZ Page

    Ubuntu 18.04.3... pretty vanilla.

    Ahh okay I hadn't tried SDR# in the Windows guest but it might be worth a try. I could also try SoapyRemote to serve up the SDRPlay to the Windows guest.. I hadn't thought of that either lol thanks for the tips!
     
  4. N0NB

    N0NB Subscriber QRZ Page

    I just received an RSPdx yesterday and set about getting things going last night and finally got it going this morning. Yes, I did sleep in between time. :)

    On my laptop running Debian testing, I was successful installing the soapysdr and cubic packages from the Debian repository which meant I needed to only build the soapysdrplay module. At first the build was failing and then I read the directions again and saw that the git download was much different with the recommended 3.06 API:

    Code:
    git clone -b API3+RSPduo https://github.com/fventuri/SoapySDRPlay ./SoapySDRPlay
    After that it built fine.

    The other thing of note is that the API 3.06 package provides a systemd service unit file that does not appear to be enabled at boot time. A simple

    Code:
    sudo systemctl start sdrplay.service
    with the RSPdx plugged into a USB port allows the soapysdr utility to find it.

    Then I launched Cubic and was greeted with a working receiver! No problem hearing the local FM broadcaster on my 160/80m doublet and then tuned to the local 75m net and had good clean copy for a few minutes.

    I suppose the proprietary nature of the API module that the compiled soapysdrplay module depends on prevents it from being packaged in the Debian repositories. The rest of the pieces are there so that made it much easier.
     
    K3RLD and KA2CZU like this.
  5. AF7XT

    AF7XT Ham Member QRZ Page

    https://github.com/cjcliffe/CubicSDR/wiki/Build-Linux

    look familiar?
    I did much the same for the RTL-SDR Blog V.3. Dongle blog https://www.rtl-sdr.com/rtl-sdr-blog-v-3-dongles-user-guide/
    At $25 it isn't even close to the radio that the SDRPlay xx are but I just needed a USB *something for a proof of concept hack.
    I still had to jump through all the hoops. :D

    *remote receiver with microwave link
     

Share This Page