ad: SDRKits-1

SDRPlay and Linux

Discussion in 'Software Defined Radio (SDR)' started by KC3SWL, Jul 23, 2019.

ad: L-HROutlet
ad: l-rl
ad: MessiPaoloni-1
ad: Left-2
ad: Left-3
ad: L-MFJ
ad: Subscribe
  1. K3RLD

    K3RLD Ham Member QRZ Page

    Ok, so if pulse audio is required and installed, I would go ahead and install pavucontrol:

    Code:
    sudo apt install pavucontrol
    After it's installed, open the software you want to use and verify it is working (for example, CubicSDR) - make sure that it is "on" and producing audio (or at least looks like it is). Then you open the pavucontrol gui and click on the "playback" tab and you should see CubicSDR listed there, and there should be a little VU meter thats pulsating along with the output of the sofware. Next to it should be a dropdown menu with various audio output methods - you should be able to select your bluetooth output or the USB soundcard. Play around with the other tabs in pavucontrol as it allows you to pipe the audio into other software as well as set the levels (volume) for each individually. On Ubuntu, the "system" volume control that is located in the upper right hand corner of the desktop is rendered useless with pulseaudio, and I suspect this is true with the Raspi, as well (which could explain why it isn't working for you).

    [edit] I should point out that in Ubuntu, at least, pavucontrol seems to "remember" the settings for various programs and hardware - so generally I only have to do this once. This can cause problems, however, as sometimes I forget to turn my Signalink off, and it takes the general audio from the system and tries to Tx it from my 706MKIIG. The last time this happend, I was "calibrating" QSSTV and during the Tx portion of the calibration, my radio was keyed for like 10 minutes as I was outside mowing the lawn or something.... thankfully there was no actual audio so the Tx output was very close to zero watts (rig was in SSB on 14.230, not FM) - but still something to keep tabs on.
     
    Last edited: Oct 22, 2019
    KA2CZU likes this.
  2. KK4NSF

    KK4NSF Ham Member QRZ Page

    you know.... all of this discussion only serves to further convince me that the SDRplay folks have failed to properly support the Linux community. That is unfortunate, since it's a great litle radio.... but it is not so great as to justify all of the BS required to make it run.
     
  3. KA2CZU

    KA2CZU XML Subscriber QRZ Page

    perhaps so, but there is a binary version available from SDRPlay that I didn't try, due to building and running other apps already.

    but it is an option for those desiring plug and play... you could start there, and then customize your system afterwards.

    Any *nix is likely more work to set up than M$oft or M$cOS.
     
  4. KA9JLM

    KA9JLM Ham Member QRZ Page

    Sometimes you have to figure it out for yourself. You learn a lot that way. :)

    I can not expect anyone to teach me how a Linux OS works.

    Sometimes you need to start with a Peek and Poke.

    The thing nice about Linux is that you can bash it, And it works better for you. :D
     
  5. KA2CZU

    KA2CZU XML Subscriber QRZ Page

    Worked great, definitely goi g to play with this more!
     
    K3RLD likes this.
  6. K6CLS

    K6CLS Ham Member QRZ Page

    that's my experience too.

    running cmake on standard issue ubuntu 19.04 on x86, can't find the libraries that were installed by obfuscated bash and binary blob. so no Makefile and can't use SDRPlay on Gnu Radio. Sad Face! $100 wasted?

    sent the info below to them via their web form... got no response,... not even ACKed that I sent in a bug report and asked for help. Yeah, Linux support.


    cls@K6CLS-P:~/src/gr-sdrplay/build$ cmake ..

    ...
    -- libsdrplay not found.
    CMake Error at lib/CMakeLists.txt:43 (message):
    SDRPlay development files not found... Please visit sdrplay, download and
    install the API


    -- Configuring incomplete, errors occurred!
    See also "/home/cls/src/gr-sdrplay/build/CMakeFiles/CMakeOutput.log".
    See also "/home/cls/src/gr-sdrplay/build/CMakeFiles/CMakeError.log".
    cls@K6CLS-P:~/src/gr-sdrplay/build$
    cls@K6CLS-P:~/src/gr-sdrplay/build$ locate libsdrplay
    /usr/local/lib/libsdrplay_api.so
    /usr/local/lib/libsdrplay_api.so.3
    /usr/local/lib/libsdrplay_api.so.3.01


    Duh! It's there. The API installer ran quietly.

    Platitudes are unhelpful. Please refrain.

    If you want to help, try installing the API libraries and getting the GRC support built.

    Yeah I suppose I could disassemble their binary blobs - against their terms of service - and fool around with cmake. but it's not my job. I'm going to go do something fun instead.

    Oh by the way, GRC works fine with 3 other SDRs I have.
     
  7. KK4NSF

    KK4NSF Ham Member QRZ Page

    agreed..... but the forum is full of such comments. I just ignore them.
     
  8. KA9JLM

    KA9JLM Ham Member QRZ Page

    No need to get Butt Hurt.

    I do apologize.
     
  9. KA8NCR

    KA8NCR Ham Member QRZ Page

    That's why it is $150.
     

Share This Page