Sb220 meter lights get brighter when i transmit

Discussion in 'Amateur Radio Amplifiers' started by KG7HVR, Nov 20, 2020.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: Left-3
ad: abrind-2
ad: Left-2
  1. KG7HVR

    KG7HVR Ham Member QRZ Page

    I replaced the capacitor bank and nothing else a month or so ago. The meters were doing this before. And you could smell that old capacitor smell so i replaced them. It solved the meter light fluctuations but now the flickering with audio is back. The hv power meter shows fluctuations following voice pattern.

    Anyone have a idea here? Failing diodes? Tube issue? Heres a quick clip . Im keying 20 or 40w am off and on here.

     
  2. W1QJ

    W1QJ Ham Member QRZ Page

    I have to ask what is it you are keying? Do you have RF drive going in? Is this AM? The reason the bulbs are getting bright is either because the amp is oscillating or you have bad bypass caps or no bypass caps on the HV or on the line voltage to the bulbs. One or the other.
     
  3. W4HWD

    W4HWD Platinum Subscriber Platinum Subscriber QRZ Page

    IT'S ALIVE!!!
     
  4. W2VW

    W2VW XML Subscriber QRZ Page

    Does this happen with a dummy load?
     
  5. G3YRO

    G3YRO Ham Member QRZ Page

    Almost certainly the panel bulbs are illuminating due to failure of one or more of the decoupling capacitors on the filament supply, C22 to C25 . . . just replace all 4.

    The HT Voltage will obviously dip under load, ie as as you talk on SSB, so the Meter will reflect this. (so it is quite normal)

    Roger G3YRO
     
    N8VIL and VE3WF like this.
  6. KG7HVR

    KG7HVR Ham Member QRZ Page

    Im not sure. I pulled the tubes and noticed one pin looks funky again. Probably flux from when i had to reflow the solder that dropped out with silverbearing solder 20201121_231357.jpg 20201121_231400.jpg
     
  7. KG7HVR

    KG7HVR Ham Member QRZ Page

    Ill have to find out what they are rated at voltage wise and maybe I have some or order more. That makes sense but who knows
     
  8. KG7HVR

    KG7HVR Ham Member QRZ Page

    I have a update. It was the tube socket for filament. I pulled the tubes. Cleaned everything. One tube wouldn't light till i cleaned the socket and re compressed the pressure clip . Works good now, no meter light changes now
    Added the diode protection for the meters while i was in there.
    Thanks guys
     
  9. G3YRO

    G3YRO Ham Member QRZ Page

    Glad you got it sorted . . .

    I must admit that I hadn't imagined that the pins on the Valve Base would be that corroded !

    Otherwise I would have suggested that first. (I would expect that you're also getting more power now too)

    Roger G3YRO
     
  10. KG7HVR

    KG7HVR Ham Member QRZ Page

    The sockets have a second part that applies pressure to the socket halves in there. They get weak. You can re compress the clip and re install it. The socket overheated slightly. Multiple issues caused it. Previous owners soldered the pin with reg low temp solder. Solder dropped out. Pin was resoldered w silver bearing solder but too much flux was left behind. Heated up and coated the pin and socket. So anyway i might just pull the sockets out of my hl2200 and swap or see if i can source new ones.
     

Share This Page

ad: elecraft