ad: vanity

RTL-SDR, What am I missing?

Discussion in 'Computers, Hardware, and Operating Systems' started by N9PCT, May 20, 2016.

Tags:
ad: L-HROutlet
ad: l-rl
ad: K5AB-Elect-1
ad: L-MFJ
ad: MessiPaoloni-1
ad: Subscribe
ad: Left-2
  1. N9PCT

    N9PCT Ham Member QRZ Page

    Hello!

    I come to you all with an interesting problem! I've installed the RTL-SDR / SDRSharp combination dozens of times, and all of them eventually worked.

    However, I have a system that refuses to yield. When I get to Zadig to install the RTL drivers, they refuse to install. I have the correct distributable, C++, .NET, etc. Weird thing though - when I open zadig and select Bulk-In Interface 0, instead of showing RTLxxxxxxxx for the installed driver, it simply says (NONE) as shown in the photos. Then when I try to install the WIN driver, it fails! A search on the problem reveals that the (NONE) problem usually isnt a problem.

    What am I missing? It has to be something dumb!

    System:
    Windows 7 Professional x64
    AMD FX 4300
    16GB DDR3
     

    Attached Files:

  2. KM4BLG

    KM4BLG Ham Member QRZ Page

    Windows may have some other underlying issue. How long has it been since you did a clean install?
     
  3. N9PCT

    N9PCT Ham Member QRZ Page

    I built the computer half way through last semester. ~two months ago. I have it quad booted with W7x64, W7x32, W10x64, and Linux Mint. This is on W7x64. Maybe I should try it on the 32 bit install. Also I'm running an Intel SSD. Maybe that could be the problem.
     
  4. KW4EK

    KW4EK Ham Member QRZ Page

    You may wish to try another version or download of Zadig as it is possible that you have a partially corrupted version or download.

    The "None" simply means that there is no preexisting driver installed for your dongle, though ordinarily Windows would have associated a driver with the dongle at the completion of its own driver search. It is also possible, if you did this quickly after inserting the dongle, that Windows is still in the process of searching for a suitable driver and you just need to wait awhile for that to complete first (i.e. your driver install may be in contention with the search still underway).

    The other question may be what version of Windows are you presently using as I know it works in Win7 and Win8.1 (32 and 64-bit), but I have never tried Win10.
     
  5. KA9JLM

    KA9JLM Ham Member QRZ Page

    In Zadig try Options / List All Devices. More devices should show up.

    What is your hardware ?

    Good Luck.
     
    Last edited: May 22, 2016
  6. N9PCT

    N9PCT Ham Member QRZ Page

    I tried re-downloading Zadig, but not from a second source. I'll have to try that yet. I am using Windows 7 Professional 64 bit. I tried installing on multiple devices after enabling "list all devices". @KA9JLM @KW4EK

    More system specs:
    chipset: AMD® 760G+SB710
    SDR: RTL2832U - R820T
     
  7. KW4EK

    KW4EK Ham Member QRZ Page

    Another thing to try, if you have not already, is disabling any antivirus software you may have running during the install as some if them really do not like the Zadig installer and may block its action.
     
  8. KA9JLM

    KA9JLM Ham Member QRZ Page

    You may want to start over and verify that Zadig.exe and RTLSDR.DLL are in the directory c:/sdrsharp.
    1. Double click on install-rtlsdr.bat from within the extracted folder. This will start a command prompt that will download all the drivers required to make SDRSharp work with RTL-SDR. The command prompt will automatically close after a few seconds when it is done. If the bat file ran successfully the files rtlsdr.dll and zadig.exe will be downloaded into the SDR# directory. If they were not downloaded then your PC or anti virus solution may be misconfigured and may have trouble running batch files (Check that the folder is not read only, and not located in the Program Files directory). If install-rtlsdr.dll fails, do a manual driver installation.
    Good Luck.
     

Share This Page