RS232/USB serial not connecting between KX2 and Mac

Discussion in 'Computers, Hardware, and Operating Systems' started by AJ6KZ, Oct 13, 2019.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-3
ad: Subscribe
ad: MessiPaoloni-1
ad: Left-2
  1. AJ6KZ

    AJ6KZ XML Subscriber QRZ Page

    I ordered an FTDI USB serial cable that I'm using with my Mac (OS 10.14) and am trying to get the KX2 utility to talk to the radio. Every time I get the "KX2 is not responding" message.

    With my scope I could see that the computer is sending on the ring and not the tip, which I believe is opposite to what the KX2 is expecting, so I cut the cable and swapped the tip and ring wires. I verified with the scope that the computer is indeed now transmitting on the tip. However, I still get the "not responding" message.

    I have tried every bps rate setting in the KX2 and when I check the output with the scope it even looks like it is trying all four data rates. The plug itself is a stereo, which the KX2 manual says is fine; it even matches what the official KX2 serial cable plug looks like.

    Have any of you experienced something like this? Any ideas?
     
  2. DF1HX

    DF1HX Premium Subscriber QRZ Page

    I am using a 13" MBP with my KX3 and the USB/serial cable suplied with the radio.
    I was used to power on radio and computer AFTER putting everything together. However after an upgrade of MacOS
    it did not work anymore but spit error messages like "not responding". I did not find the culprit but HOTPLUGGED i.e powered on radio and computer first
    than connected the cable. That works!
    BTW date rate i use with my KX3 is 38.000 bps.
    Cheers es gl, thomas
     
  3. AJ6KZ

    AJ6KZ XML Subscriber QRZ Page

    Ah, I had high hopes! But it didn't work for me. Thanks for taking the time to post! I'm beginning to suspect that either the cable end is not making good contact or there is something wrong with the radio.
     
  4. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Did you allow the connection in your Privacy settings on the Mac (Security & Privacy pane of the System Preferences, on the bottom of the General tab)?

    Did you try installing the FTDI drivers from the FTDI site? In most cases, FTDI chips just work with macOS as the driver is included in the kernel, but sometimes I've had to install the FTDI VCP drivers from the FTDI website: but that's been some time since I had to do that, and not with 10.14.

    Are you sure it is a legit FTDI cable? Although not as bad as the fake Prolific problem, fake FTDI chips do exist, especially on eBay. Usually they simply won't work no matter what you do.
     
  5. AJ6KZ

    AJ6KZ XML Subscriber QRZ Page

    That's a really good point about the privacy settings. Later I will double check that. However, I had a scope on the lines in between the computer and the radio and I could see the signal was going out, but on the other line nothing was coming back from the radio.

    I deleted old FTDI and Prolific drivers that were still installed and re-installed FTDI drivers from their site. At this point it's ether the chip in the cable or there is actually something wrong with the radio. To eliminate the cable question I went ahead and ordered a USB serial cable directly from Elecraft. I will post the results of everything here.

    Thanks for the suggestions!
     
    Last edited: Oct 17, 2019
  6. AJ6KZ

    AJ6KZ XML Subscriber QRZ Page

    My Elecraft USB/Serial cable arrived today. I plugged it in and when I tested the communication with the radio it worked the first time. I'm guessing the FTDI chip in my other cable was either counterfeit or just bad.
     
    K3DCW likes this.
  7. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Very glad you got it working!
     
    AJ6KZ likes this.

Share This Page