ad: elecraft

RS-BA1 USB device not recognized

Discussion in 'Amateur Radio Software' started by KE9T, Nov 24, 2019.

ad: L-HROutlet
ad: l-rl
ad: FBNews-1
ad: L-MFJ
ad: Left-2
ad: Left-3
ad: Subscribe
  1. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    One thing that completely mess's up the 9100 radio connection here is if I turn the radio off from the front panel "power" push button then turn it back on. I end up restoring the connection by completely shutting down the external power supply to "hard reboot" the rig. So the sequence would be turn off the external power supply completely, after the voltage drains turn it back on then turn the radio on from the front panel "power" button If I merely turn the radio back on without powering off the power supply it will never find the USB ports. My linear power supply has an old style power switch that manually disconnects the AC.
    The radios processor (and probably the 7300's too) stays alive as long as the radio has DC power supplied to it, so to do a total cold boot I end up powering off the linear power supply.

    Don't know if this will help you with a 7300 but with a 9100 I have to use a PC as the network connection, with RS-Ba1 providing the bridge from radio USBserial to network connection, I think the 7300 had a lan connection built in. You may have to setup the router in a similar way.
    I'm port forwarding the USB ports through the house router from this PC, I can ping the radios' server pc from the private network (192,168,xxx,xxx) If I was to try from the web I'm pretty sure I would have to forward the IP address of the PC (like I do with a ESP8266 nodemcu)
    AND this might be old school but this PCs' (wired lan connection) ip address is DHCP reserved in the router , you may have to do that with the 7300 so it recognizes its name and gives it the same ip address
    Can you ping the 7300's IP address from your private network, then once you can, route the Rigs' IP address to your the IP your internet provider gives you, try pinging that internet address
    When I was setting up RS-BA1 if I got things messed up merely turning the 9100 off from the front panel "power" button would not allow the hardware to be rediscovered so I would shut the external power supply off, then restart it then the radio to get things to be discovered.

    hope this helps
     
  2. OH8HHP

    OH8HHP Ham Member QRZ Page

    Small update, if keep power supply always on, no windows warnings related to USB device. Radio self can be on or off when starting PC.
    7300 don't have LAN connection, it has to use server computer to manage remote connections. Radio is connected to PC via USB cable. Still cannot get any connection even try inside of my private LAN, not over "internet" Very frustrating...
     
  3. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    Dont know why I thought the 7300 had a network connection built in, so it should be the same setup PC wise as the 9100, different in the rigs of course
    unfortunately I have no win10 to try here, I wiped out my win10 laptop and put linux on it
    Comparing settings with a working win10 setup might shed some light

    I would strongly suggest checking out this group.io https://groups.io/g/rs-ba1
    lots of questions/info there for 7300 and rs-ba1 and win7 or 10 with remote issues
    another group.io https://groups.io/g/ic-7300 almost 4800 members

    can you run the remote utility on the PC thats USB'd to the rig and connect to the Rig you setup in there. You should see the AF bar grapf moving if the radio is tuned onto a conversation. If that works at least you know the remote utility is getting the radio.
    From there its a matter of following the flow. Checking the server pc for firewall permissions for programs, incoming and outgoing rules, then the home router for port forwarding, then check the same firewall permissions, incoming and outgoing rules
    Good idea to double check the settings for the remote utility in both setups.
    I'm running the remote utility on the server pc just by itself not connected in that window
    and on the laptop I'm just running the remote utility and have connected to the radio in that window and I'm hearing audio from the 9100, once I start the remote control program its then I can control the rig
    Non of this worked until I got firewalls at both ends setup with permissions for ICOM and incoming rules setup, then port forwarded in the home router
    There are some good you tube videos as well, dont give up its likely just a setting thats blocking the flow- here it was the router port forwarding that was hindering things. The remote worked so slick last summer from my garage or pool deck that I'm putting my antenna switch on wifi so I can change antennas remotely from the web browser.
     

Share This Page