Rig Control Problems (HamLib)

Discussion in 'Mac Ham Radio on macOS & iOS' started by KO0N, Apr 21, 2020.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Subscribe
ad: L-MFJ
ad: abrind-2
ad: Left-2
  1. KO0N

    KO0N Ham Member QRZ Page

    I set my 2012 MacBook Pro up a way back when and, I has worked for me until recently, I upgraded to Mohave and, my rig control does not connect anymore; all of my digital programs worked before the upgrade.
     
  2. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Sounds like a cable driver problem. What kind of rig? What kind of connection/cable between them? Have you tried installing the latest drivers for whichever cable you're using, and have you authorized them to run under the General Tab of the Security & Privacy pane in System Preferences?
     
  3. KO0N

    KO0N Ham Member QRZ Page

    Hello Dave,

    The Radio is the Icom 706 and I am not sure what brand of Serial to USB cable; it's the same cable and driver setup that worked through 3 IOS software upgrades; all the way up from Snow Leopard until the latest Mohave upgrade. The Apple computer was not being used for radio for quite a while as, I used the Windows machine until I was forced to upgrade to Windows 10 (another story for another forum).

    So, I put the MacBook back into service only to discover that it could not control the radio; I authorised the app in the Privacy preferences and, see the LEDs on the serial cable show signals when I turn the dial on the radio.

    Wasn't sure where to start T/S the setup as, it runs on Windows 10 so, I figured something changed in the operating system or, matching of the cord to the radio.
     
  4. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Ok, and what software are you trying to connect?
     

Share This Page