QYT-7900D Bad Behavior

Discussion in 'Radio Circuits, Repair & Performance' started by KG7FIU, Jul 7, 2019.

Tags:
ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: MessiPaoloni-1
ad: Subscribe
ad: Left-2
ad: Left-3
  1. KG7FIU

    KG7FIU Ham Member QRZ Page

    This is my Chinese QYT-7900D radio.
    Yes, I know they are no good -- but it had been working OK for about a year. Suddenly it's started going into wild oscillations. Happens almost immediately after powering on. Any hope -- or time to throw the thing in the trashcan?

     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    Did you use Chirp to program it ?
     
  3. KG7FIU

    KG7FIU Ham Member QRZ Page

    Yes, originally used Chirp to program all the freq's. But don't think it's software.
    Performed a factory reset, and it's still exhibiting the same craziness.
     
  4. KA9JLM

    KA9JLM Ham Member QRZ Page

    The reason that I ask, Is because some radios like that should not have anything in Memory location 0 (zero).

    The first memory channel used should be memory 1. But chirp lets you put something in 0.

    Does it do that with the mic removed ? Is your power supply DC clean ?
     
  5. KG7FIU

    KG7FIU Ham Member QRZ Page

    Yes, thanks for trying to help. Removing mic makes no diff. Took radio outside and connected radio to car battery -- same deal.
    I think it's just a piece of junk...
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    That is a bummer.

    Before trashing, You may want to check the connection that connects the control head.
     

Share This Page