Problems with WJST-X and Kenwood TS-850s

Discussion in 'Amateur Radio Software' started by N2KWO, Jun 27, 2018.

ad: L-HROutlet
ad: l-rl
ad: l-BCInc
ad: l-assoc
ad: L-MFJ
ad: Subscribe
ad: MessiPaoloni-1
  1. N2KWO

    N2KWO Subscriber QRZ Page

    I've been attempting to configure WJST-X directly with the Kewood TS-850 (vs using HRD) and the first thing that happens is the CAT control button turns green (should be a good sign) and then the rig is immediaty keyed and stays keyed even if I shut down the program (or shut down the whole computer). Sometimes the rig stays keyed and I have to do a microprocessor reset.
    I have tried using HRD (the free version) with slighltty better results. I am decoding signal and I doulble click to start a QSO but WJST-X sends commands to control the rig (via HRD) and it sends the frequency off into lala-land (usually to about 7.210Mhz). Then the dislpay (WJST-X) shows 13.900 Mhz and I have to shut down the program and resart it to get the program to display the correct frequency.
    Any suggestions are welcome. This is very frustrating.
    Computer: Lenova
    Operating System: Windows 7 with all updates
    CAT cable: xggcomms.com Kenwood USB Digimode Interface
    Rig: Kenwood TS-850 w/auto-tuner and DRU-2 (from jahnkeelectronics.com
    Software:
    WSJT-X Version 1.9.1
    HamRadioDeluxe v5.24.0.38
    N1MM v 1.0.7208
     
  2. KP4SX

    KP4SX Subscriber QRZ Page

    Strange. My first flinch would suggest RF getting into the system. Or rig audio is triggering it into xmt and then all the crazy stuff starts happening.
     
  3. N2KWO

    N2KWO Subscriber QRZ Page

    No, there is no RF issue. It is an issue with the software. Having run a clean shack for many years I know RF issues when I see them. This happens with a dummy load attached and running 10 watts. It's a issue with controling the rig and the PTT.
    The PTT immediately keys when I try to config for Kenwood TS-850s no matter the RF output (dummy load at 10w). RF has to be keyed and the keying is the problem (with the software). I've tried other settings (key via DTR, etc) but it still keys the rig immediatly apon config.
    If I control the rig with HRD it keys but the software changes the frequency (sending messages to change the freq way off of where it should be) and THEN keys the rig at the wrong freq. I end up sending out a JT8 signal in the middle of the Upper Side Band area (vs USB the protocol) . The sequence is critical: change freq and then key(PTT). The freq is changed FIRST.
    I can sit and listen and see that the audio is good and decoding things. But the second I double click to tell the software to take contron then everythng goes south.
    I've been using HRD (as well as N2MM) and have no issues with control with those programs for years now. No odd RF issues, etc, even at the legel limit. So I really don't see this as an RF issue.
    But thanks for the post. It is appreciated even though I'm rather pissed (LOL). Having had to deal with sub-standard software for all of my career makes me belligerent. I've earned the badge.
    Chuck
    N2KWO
     
  4. KP4SX

    KP4SX Subscriber QRZ Page

    I never had any experiences like that with WSJT-X. Good luck with it.
     
    ND6M likes this.

Share This Page